summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-09 15:09:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-09 15:09:29 +0000
commit03b11a31870a04361ba024166dbaab40abc1ffd4 (patch)
tree33315ccd804de7052c07571223cbdbe591ce46f6 /dev-libs
parentDelete older ebuild. (diff)
downloadhistorical-03b11a31870a04361ba024166dbaab40abc1ffd4.tar.gz
historical-03b11a31870a04361ba024166dbaab40abc1ffd4.tar.bz2
historical-03b11a31870a04361ba024166dbaab40abc1ffd4.zip
Version bump.
Package-Manager: portage-2.2.0_alpha32_p5/cvs/Linux x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian-bindings/ChangeLog10
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild138
-rw-r--r--dev-libs/xapian/ChangeLog8
-rw-r--r--dev-libs/xapian/xapian-1.2.5.ebuild29
4 files changed, 182 insertions, 3 deletions
diff --git a/dev-libs/xapian-bindings/ChangeLog b/dev-libs/xapian-bindings/ChangeLog
index 76be3c329b91..bd74e01cba04 100644
--- a/dev-libs/xapian-bindings/ChangeLog
+++ b/dev-libs/xapian-bindings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/xapian-bindings
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.18 2010/12/23 12:10:54 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.19 2011/05/09 15:09:29 arfrever Exp $
+
+*xapian-bindings-1.2.5 (09 May 2011)
+
+ 09 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +xapian-bindings-1.2.5.ebuild:
+ Version bump.
*xapian-bindings-1.2.4 (23 Dec 2010)
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild
new file mode 100644
index 000000000000..12925a90bd2d
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild,v 1.1 2011/05/09 15:09:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit java-pkg-opt-2 mono python
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="java mono php python ruby tcl"
+
+COMMONDEPEND="=dev-libs/xapian-${PV}*
+ mono? ( >=dev-lang/mono-1.0.8 )
+ php? ( >=dev-lang/php-4 )
+ ruby? ( dev-lang/ruby )
+ tcl? ( >=dev-lang/tcl-8.1 )"
+DEPEND="${COMMONDEPEND}
+ python? ( >=dev-lang/swig-1.3.29-r1 )
+ java? ( >=virtual/jdk-1.3 )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.3 )"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed \
+ -e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
+ -e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian$(PYTHON_SO)|' \
+ -i python/Makefile.{am,in} || die "sed failed"
+}
+
+src_configure() {
+ if use java; then
+ CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
+ fi
+ econf \
+ $(use_with java) \
+ $(use_with mono csharp) \
+ $(use_with php) \
+ $(use_with python) \
+ $(use_with ruby) \
+ $(use_with tcl)
+
+ # Python bindings are built/tested/installed manually.
+ sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+ building() {
+ emake \
+ PYTHON="$(PYTHON)" \
+ PYTHON_INC="$(python_get_includedir)" \
+ PYTHON_LIB="$(python_get_libdir)" \
+ pkgpylibdir="$(python_get_sitedir)/xapian"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_test() {
+ default
+
+ if use python; then
+ testing() {
+ emake \
+ PYTHON="$(PYTHON)" \
+ PYTHON_INC="$(python_get_includedir)" \
+ PYTHON_LIB="$(python_get_libdir)" \
+ pkgpylibdir="$(python_get_sitedir)/xapian" \
+ VERBOSE="1" \
+ check
+ }
+ python_execute_function -s --source-dir python testing
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use java; then
+ java-pkg_dojar java/built/xapian_jni.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
+ rm "${D}/${S}/java/built/libxapian_jni.so"
+ rmdir -p "${D}/${S}/java/built"
+ rmdir -p "${D}/${S}/java/native"
+ fi
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON="$(PYTHON)" \
+ PYTHON_INC="$(python_get_includedir)" \
+ PYTHON_LIB="$(python_get_libdir)" \
+ pkgpylibdir="$(python_get_sitedir)/xapian" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+ fi
+
+ # For some USE combinations this directory is not created
+ if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize xapian
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup xapian
+ fi
+}
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index 57586f360a45..676bb2c2fe96 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.55 2011/03/05 01:05:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.56 2011/05/09 15:08:19 arfrever Exp $
+
+*xapian-1.2.5 (09 May 2011)
+
+ 09 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +xapian-1.2.5.ebuild:
+ Version bump.
05 Mar 2011; Brent Baude <ranger@gentoo.org> xapian-1.2.4.ebuild:
stable ppc, bug 352734
diff --git a/dev-libs/xapian/xapian-1.2.5.ebuild b/dev-libs/xapian/xapian-1.2.5.ebuild
new file mode 100644
index 000000000000..e642ef9df3f5
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.5.ebuild,v 1.1 2011/05/09 15:08:19 arfrever Exp $
+
+EAPI="3"
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS || die "dodoc failed"
+}