summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-11-09 15:17:00 +0000
committerDan Armak <danarmak@gentoo.org>2001-11-09 15:17:00 +0000
commited1cc616bf9957230abd5aef11b84af0dc82122d (patch)
tree5fafa1be0a4e7a7eab26777c7f713baffb5552a0 /dev-libs
parentupdated to latest version and removed a old version (diff)
downloadhistorical-ed1cc616bf9957230abd5aef11b84af0dc82122d.tar.gz
historical-ed1cc616bf9957230abd5aef11b84af0dc82122d.tar.bz2
historical-ed1cc616bf9957230abd5aef11b84af0dc82122d.zip
new version of library
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.4.91
-rw-r--r--dev-libs/libxml2/libxml2-2.4.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.4.9 b/dev-libs/libxml2/files/digest-libxml2-2.4.9
new file mode 100644
index 000000000000..346c94180581
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.4.9
@@ -0,0 +1 @@
+MD5 f9b9adae878c2d851804cc403da085ea libxml2-2.4.9.tar.gz 1556480
diff --git a/dev-libs/libxml2/libxml2-2.4.9.ebuild b/dev-libs/libxml2/libxml2-2.4.9.ebuild
new file mode 100644
index 000000000000..a79743202c1a
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.4.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.9.ebuild,v 1.1 2001/11/09 15:17:00 danarmak Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libxml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libxml/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zlib || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}