summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-31 06:35:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-31 06:35:59 +0000
commit1756c757c9b5c68dc7db8d8c41b4a8bc7c3b3a0d (patch)
treeb17d971e5fba8e57fa4673b9ae80fb8ecf163031 /dev-lisp/cl-clx
parentPackage-Manager: portage-2.0.51.19 (diff)
downloadhistorical-1756c757c9b5c68dc7db8d8c41b4a8bc7c3b3a0d.tar.gz
historical-1756c757c9b5c68dc7db8d8c41b4a8bc7c3b3a0d.tar.bz2
historical-1756c757c9b5c68dc7db8d8c41b4a8bc7c3b3a0d.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lisp/cl-clx')
-rw-r--r--dev-lisp/cl-clx/ChangeLog8
-rw-r--r--dev-lisp/cl-clx/Manifest5
-rw-r--r--dev-lisp/cl-clx/cl-clx-0.6.1.ebuild38
-rw-r--r--dev-lisp/cl-clx/files/0.6.1-gentoo.patch108
-rw-r--r--dev-lisp/cl-clx/files/digest-cl-clx-0.6.11
5 files changed, 158 insertions, 2 deletions
diff --git a/dev-lisp/cl-clx/ChangeLog b/dev-lisp/cl-clx/ChangeLog
index 255fcc109ea4..792ece79b8c9 100644
--- a/dev-lisp/cl-clx/ChangeLog
+++ b/dev-lisp/cl-clx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cl-clx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx/ChangeLog,v 1.3 2005/03/18 07:22:47 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx/ChangeLog,v 1.4 2005/03/31 06:35:59 mkennedy Exp $
+
+*cl-clx-0.6.1 (31 Mar 2005)
+
+ 31 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.6.1-gentoo.patch, +cl-clx-0.6.1.ebuild:
+ New upstream version.
18 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> cl-clx-0.6.ebuild:
Keywording for ~amd64
diff --git a/dev-lisp/cl-clx/Manifest b/dev-lisp/cl-clx/Manifest
index 1b63aedd7620..6b0a37657c7f 100644
--- a/dev-lisp/cl-clx/Manifest
+++ b/dev-lisp/cl-clx/Manifest
@@ -1,5 +1,8 @@
-MD5 7af6df4a736a803a48556c0342d64618 ChangeLog 636
+MD5 7f09d3e0c99cece1b30ff13b50d80f2a cl-clx-0.6.1.ebuild 982
MD5 1013e3edf881c1f568244ebe9eb5a4cc cl-clx-0.6.ebuild 878
MD5 288135e37690bedcc1d596787cf11501 metadata.xml 666
+MD5 139aafc5c2764049e6bf61e219ff8fc7 ChangeLog 794
MD5 9602b9431399414d99fdec7b1fdf2447 files/0.6-gentoo.patch 4695
MD5 57d788a467c69678d85c9e20a042985c files/digest-cl-clx-0.6 59
+MD5 de0efad2dd952443ec5df21b3b4d8590 files/digest-cl-clx-0.6.1 61
+MD5 f28b823114c37c11f75c9d1d6e6a944c files/0.6.1-gentoo.patch 3860
diff --git a/dev-lisp/cl-clx/cl-clx-0.6.1.ebuild b/dev-lisp/cl-clx/cl-clx-0.6.1.ebuild
new file mode 100644
index 000000000000..e98e29dd261f
--- /dev/null
+++ b/dev-lisp/cl-clx/cl-clx-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx/cl-clx-0.6.1.ebuild,v 1.1 2005/03/31 06:35:59 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="Portable CLX"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/ http://www.cliki.net/CLX"
+SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller"
+
+CLPACKAGE=clx
+
+S=${WORKDIR}/clx_${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+}
+
+src_install() {
+ for i in . demo test debug; do
+ insinto /usr/share/common-lisp/source/clx/${i}
+ doins ${S}/${i}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/clx
+ doins clx.asd NEWS CHANGES README README-R5
+ insinto /usr/share/common-lisp/source/manual
+ doins manual/clx.texinfo
+ common-lisp-system-symlink
+ dodoc CHANGES NEWS README*
+}
diff --git a/dev-lisp/cl-clx/files/0.6.1-gentoo.patch b/dev-lisp/cl-clx/files/0.6.1-gentoo.patch
new file mode 100644
index 000000000000..4f3a63ee31c3
--- /dev/null
+++ b/dev-lisp/cl-clx/files/0.6.1-gentoo.patch
@@ -0,0 +1,108 @@
+diff -ur clx_0.6.1.orig/clx.asd clx_0.6.1/clx.asd
+--- clx_0.6.1.orig/clx.asd 2005-03-29 08:42:20.000000000 -0600
++++ clx_0.6.1/clx.asd 2005-03-30 23:55:19.000000000 -0600
+@@ -35,7 +35,7 @@
+ (defclass legacy-file (static-file) ())
+
+ (defsystem CLX
+- :depends-on (sb-bsd-sockets)
++ :depends-on (#+sbcl sb-bsd-sockets)
+ :version "0.6.1"
+ :serial t
+ :default-component-class clx-source-file
+Only in clx_0.6.1: clx.asd.~1.23.~
+diff -ur clx_0.6.1.orig/depdefs.lisp clx_0.6.1/depdefs.lisp
+--- clx_0.6.1.orig/depdefs.lisp 2003-06-05 15:18:22.000000000 -0500
++++ clx_0.6.1/depdefs.lisp 2005-03-31 00:15:05.000000000 -0600
+@@ -400,10 +400,10 @@
+ (eval-when (:compile-toplevel :load-toplevel :execute)
+ ;; FIXME: maybe we should reevaluate this?
+ (defvar *def-clx-class-use-defclass*
+- #+Genera t
++ #+(or Genera sbcl) t
+ #+(and cmu pcl) '(XLIB:DRAWABLE XLIB:WINDOW XLIB:PIXMAP)
+ #+(and cmu (not pcl)) nil
+- #-(or Genera cmu) nil
++ #-(or Genera cmu sbcl) nil
+ "Controls whether DEF-CLX-CLASS uses DEFCLASS.
+
+ If it is a list, it is interpreted by DEF-CLX-CLASS to be a list of
+Only in clx_0.6.1: depdefs.lisp.~1.4.~
+diff -ur clx_0.6.1.orig/dependent.lisp clx_0.6.1/dependent.lisp
+--- clx_0.6.1.orig/dependent.lisp 2004-06-11 07:18:17.000000000 -0500
++++ clx_0.6.1/dependent.lisp 2005-03-31 00:20:25.000000000 -0600
+@@ -1511,11 +1511,16 @@
+ (cdr (host-address host)))
+ :foreign-port (+ *x-tcp-port* display)))
+
+-#+(or sbcl ecl)
++#+(or sbcl ecl cmu)
+ (defconstant +X-unix-socket-path+
+ "/tmp/.X11-unix/X"
+ "The location of the X socket")
+
++#+(or sbcl ecl CMU)
++(defconstant +X-tcp-port+
++ 6000
++ "The TCP port number for X")
++
+ #+sbcl
+ (defun open-x-stream (host display protocol)
+ (declare (ignore protocol)
+@@ -1528,11 +1533,22 @@
+ (let ((host (car (host-ent-addresses (get-host-by-name host)))))
+ (when host
+ (let ((s (make-instance 'inet-socket :type :stream :protocol :tcp)))
+- (socket-connect s host (+ 6000 display))
++ (socket-connect s host (+ +X-tcp-port+ display))
+ s))))
+ :element-type '(unsigned-byte 8)
+ :input t :output t :buffering :none))
+
++#+CMU
++(defun open-x-stream (host display protocol)
++ (declare (ignore protocol)
++ (type (integer 0) display))
++ (system:make-fd-stream
++ (if (or (string= host "") (string= host "unix"))
++ (ext:connect-to-unix-socket (format nil "~A~D" +X-unix-socket-path+ display))
++ (ext:connect-to-inet-socket host (+ +X-tcp-port+ display)))
++ :input t :output t :element-type '(unsigned-byte 8)))
++
++
+ #+ecl
+ (defun open-x-stream (host display protocol)
+ (declare (ignore protocol)
+@@ -1541,7 +1557,7 @@
+ (if (or (string= host "") (string= host "unix")) ; AF_UNIX doamin socket
+ (sys::open-unix-socket-stream
+ (format nil "~A~D" +X-unix-socket-path+ display))
+- (si::open-client-stream host (+ 6000 display)))))
++ (si::open-client-stream host (+ +X-tcp-port+ display)))))
+
+ ;;; BUFFER-READ-DEFAULT - read data from the X stream
+
+@@ -3092,7 +3108,7 @@
+ (defmacro with-underlying-simple-vector
+ ((variable element-type pixarray) &body body)
+ (declare (ignore element-type))
+- `(#+cmu kernel::with-array-data #+sbcl sb-kernel:with-array-data
++ `(#+cmu lisp::with-array-data #+sbcl sb-kernel:with-array-data
+ ((,variable ,pixarray) (start) (end))
+ (declare (ignore start end))
+ ,@body))
+@@ -3505,11 +3521,11 @@
+ height width)
+ (declare (type array-index source-width sx sy dest-width dx dy height width))
+ #.(declare-buffun)
+- (kernel::with-array-data ((sdata source)
++ (lisp::with-array-data ((sdata source)
+ (sstart)
+ (send))
+ (declare (ignore send))
+- (kernel::with-array-data ((ddata dest)
++ (lisp::with-array-data ((ddata dest)
+ (dstart)
+ (dend))
+ (declare (ignore dend))
+Only in clx_0.6.1: dependent.lisp.~1.19.~
diff --git a/dev-lisp/cl-clx/files/digest-cl-clx-0.6.1 b/dev-lisp/cl-clx/files/digest-cl-clx-0.6.1
new file mode 100644
index 000000000000..f67bedd828a1
--- /dev/null
+++ b/dev-lisp/cl-clx/files/digest-cl-clx-0.6.1
@@ -0,0 +1 @@
+MD5 2765f8cdf80c9865e2d4d7494983d9e3 clx_0.6.1.tar.gz 408067