summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:53:04 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:53:04 +0000
commit617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f (patch)
treebcfe11291f5c920da39dfc65ba00f51356086a04 /dev-lisp/cl-phtml
parentDEPEND on sed >= 4 (diff)
downloadhistorical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.tar.gz
historical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.tar.bz2
historical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-phtml')
-rw-r--r--dev-lisp/cl-phtml/ChangeLog8
-rw-r--r--dev-lisp/cl-phtml/Manifest6
-rw-r--r--dev-lisp/cl-phtml/cl-phtml-20030325.ebuild34
-rw-r--r--dev-lisp/cl-phtml/files/digest-cl-phtml-200303251
-rw-r--r--dev-lisp/cl-phtml/files/phtml-gentoo.patch22
-rw-r--r--dev-lisp/cl-phtml/files/phtml.asd6
6 files changed, 77 insertions, 0 deletions
diff --git a/dev-lisp/cl-phtml/ChangeLog b/dev-lisp/cl-phtml/ChangeLog
new file mode 100644
index 000000000000..ee27efca3e4c
--- /dev/null
+++ b/dev-lisp/cl-phtml/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cl-phtml
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-phtml/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+*cl-phtml-20030325 (07 Jul 2003)
+
+ 07 Jul 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ initial import
diff --git a/dev-lisp/cl-phtml/Manifest b/dev-lisp/cl-phtml/Manifest
new file mode 100644
index 000000000000..738258f5c60a
--- /dev/null
+++ b/dev-lisp/cl-phtml/Manifest
@@ -0,0 +1,6 @@
+MD5 4f363d91a8ab4b6e1bd771639a15a3d4 ChangeLog 323
+MD5 0a2722e2fc707dc23cbf2a0ff54ab8bf cl-phtml-20030325.ebuild 659
+MD5 f76feb0f8a7d38ddaddbe07f3f4a3f4e cl-phtml-20030325.ebuild~ 610
+MD5 8bcf59b3a906cd6df44abc806e93e5e0 files/phtml.asd 135
+MD5 d98c560d9a5766c119efb55c9376fc3a files/phtml.asd~ 24
+MD5 f63cd1b313a37c1b83b1f3683ea80deb files/digest-cl-phtml-20030325 68
diff --git a/dev-lisp/cl-phtml/cl-phtml-20030325.ebuild b/dev-lisp/cl-phtml/cl-phtml-20030325.ebuild
new file mode 100644
index 000000000000..5d2d3185beb0
--- /dev/null
+++ b/dev-lisp/cl-phtml/cl-phtml-20030325.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-phtml/cl-phtml-20030325.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp HTML parser which can be used with cl-htmlgen."
+HOMEPAGE="http://opensource.franz.com/xmlutils/index.html"
+SRC_URI="mirror://gentoo/xmlutils-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-acl-compat"
+
+CLPACKAGE=phtml
+
+S=${WORKDIR}/xmlutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/phtml-gentoo.patch || die
+ for i in *.cl ; do mv $i ${i/.cl/.lisp} ; done
+}
+
+src_install() {
+ common-lisp-install phtml.lisp ${FILESDIR}/phtml.asd
+ # phtml-test.lisp
+ common-lisp-system-symlink
+ dodoc ChangeLog phtml.txt phtml.htm
+}
diff --git a/dev-lisp/cl-phtml/files/digest-cl-phtml-20030325 b/dev-lisp/cl-phtml/files/digest-cl-phtml-20030325
new file mode 100644
index 000000000000..b85e9d2078dd
--- /dev/null
+++ b/dev-lisp/cl-phtml/files/digest-cl-phtml-20030325
@@ -0,0 +1 @@
+MD5 75d7ecb096f491b1628130e1883bee14 xmlutils-20030325.tar.gz 55204
diff --git a/dev-lisp/cl-phtml/files/phtml-gentoo.patch b/dev-lisp/cl-phtml/files/phtml-gentoo.patch
new file mode 100644
index 000000000000..c0052057c7d4
--- /dev/null
+++ b/dev-lisp/cl-phtml/files/phtml-gentoo.patch
@@ -0,0 +1,22 @@
+diff -u xmlutils.orig/phtml.cl xmlutils/phtml.cl
+--- xmlutils.orig/phtml.cl 2003-04-01 00:41:00.000000000 -0600
++++ xmlutils/phtml.cl 2003-06-09 19:25:13.000000000 -0500
+@@ -1,8 +1,3 @@
+-(sys:defpatch "phtml" 1
+- "parse-html close tag closes consecutive identical open tags."
+- :type :system
+- :post-loadable t)
+-
+ ;; copyright (c) 1986-2000 Franz Inc, Berkeley, CA
+ ;;
+ ;; This code is free software; you can redistribute it and/or
+@@ -48,7 +43,7 @@
+ ;
+
+ (defpackage net.html.parser
+- (:use :lisp :clos :excl)
++ (:use :lisp :excl)
+ (:export
+ #:phtml-internal
+ #:parse-html))
+Only in xmlutils: phtml.cl~
diff --git a/dev-lisp/cl-phtml/files/phtml.asd b/dev-lisp/cl-phtml/files/phtml.asd
new file mode 100644
index 000000000000..b2147e33e925
--- /dev/null
+++ b/dev-lisp/cl-phtml/files/phtml.asd
@@ -0,0 +1,6 @@
+
+(in-package "CL-USER")
+
+(asdf:defsystem phtml
+ :depends-on (acl-compat)
+ :components ((:file "phtml")))