summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-10-05 07:54:53 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-10-05 07:54:53 +0000
commit3bd08b57c1c88a8c3052b2aea633fe196d1c828a (patch)
tree04c8bd77f40623cc948db2abc3634c21cb2084dc /dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild
parentStable on x86, ppc and alpha. (diff)
downloadhistorical-3bd08b57c1c88a8c3052b2aea633fe196d1c828a.tar.gz
historical-3bd08b57c1c88a8c3052b2aea633fe196d1c828a.tar.bz2
historical-3bd08b57c1c88a8c3052b2aea633fe196d1c828a.zip
New ebuild, ocaml dependency sorter. Fixes bug #25343.
Diffstat (limited to 'dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild')
-rw-r--r--dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild b/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild
new file mode 100644
index 000000000000..c3f2191fcede
--- /dev/null
+++ b/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild,v 1.1 2004/10/05 07:54:53 mattam Exp $
+
+DESCRIPTION="A dependency sorter for OCaml source files"
+HOMEPAGE="http://dimitri.mutu.net/ocaml.html"
+
+SRC_URI="ftp://quatramaran.ens.fr/pub/ara/ocamldsort/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+
+SLOT="0"
+
+KEYWORDS="x86 ppc"
+
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.06"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin MANDIR=${D}/usr/share/man install
+ dodoc README
+}
+