summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-27 22:50:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-27 22:50:27 +0000
commitce0b8b917a36ba0c3c51c3d4c3720ea09f424609 (patch)
treed558ac8264680706b5ece41eca467ea096aeaece /dev-ml
parentAdd support for disabling debug useflag usage for old oasis versions (diff)
downloadhistorical-ce0b8b917a36ba0c3c51c3d4c3720ea09f424609.tar.gz
historical-ce0b8b917a36ba0c3c51c3d4c3720ea09f424609.tar.bz2
historical-ce0b8b917a36ba0c3c51c3d4c3720ea09f424609.zip
initial import, ebuild based on the one from Vladimir Ivanov in bug #355765 and converted to oasis.eclass
Package-Manager: portage-2.2.0_alpha95/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlify/ChangeLog11
-rw-r--r--dev-ml/ocamlify/Manifest14
-rw-r--r--dev-ml/ocamlify/metadata.xml5
-rw-r--r--dev-ml/ocamlify/ocamlify-0.0.1.ebuild23
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/ocamlify/ChangeLog b/dev-ml/ocamlify/ChangeLog
new file mode 100644
index 000000000000..c3bc00bb448a
--- /dev/null
+++ b/dev-ml/ocamlify/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocamlify
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlify/ChangeLog,v 1.1 2012/03/27 22:50:27 aballier Exp $
+
+*ocamlify-0.0.1 (27 Mar 2012)
+
+ 27 Mar 2012; Alexis Ballier <aballier@gentoo.org> +ocamlify-0.0.1.ebuild,
+ +metadata.xml:
+ initial import, ebuild based on the one from Vladimir Ivanov in bug #355765
+ and converted to oasis.eclass
+
diff --git a/dev-ml/ocamlify/Manifest b/dev-ml/ocamlify/Manifest
new file mode 100644
index 000000000000..d864bd66b7c3
--- /dev/null
+++ b/dev-ml/ocamlify/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST ocamlify-0.0.1.tar.gz 46210 RMD160 0a796a55491749b0677a5f956a6ed261b6bac408 SHA1 edac27eb484f151076d645a8b8b6d502e5f72376 SHA256 75f20c65b834165c98b606b03c7f28c09c03f3ebf12b69dae8ba2d2cf75836c9
+EBUILD ocamlify-0.0.1.ebuild 646 RMD160 57e1416e65d0ca386d964ffe93cc49f95fad29fe SHA1 dcf71d9a18585cfc432d7109c04b4a2ebc3729ba SHA256 b42e86eb8ca86fe044aed49f7bd6743308e54bbdff73588e1e4bf3677cc25292
+MISC ChangeLog 440 RMD160 b836aecc3f6049e54bf486063fe83adbf5b71fdc SHA1 df94848532fa956a9f69b3f9a0fcd3a0ed78b4c9 SHA256 0960d355ba7eeb745ca0311091d922460a941d5a8fd4bc3b44269148e6e5817b
+MISC metadata.xml 155 RMD160 dfaa057e679b01302a807c75a32a910098b26809 SHA1 94024f83dcacbb53e92be090dd0f994ec93dc90d SHA256 118048376ebb76f57628b0819f3de4856e73959c2578c88715d37ea2d1e0af81
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEARECAAYFAk9yRDgACgkQvFcC4BYPU0pNcACfU8N6MunHIdPZTMOYk28qTcuk
+KasAoIlFxL/ZXrSboV+NKXyPloX2r8cr
+=WJeM
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/ocamlify/metadata.xml b/dev-ml/ocamlify/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ocamlify/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlify/ocamlify-0.0.1.ebuild b/dev-ml/ocamlify/ocamlify-0.0.1.ebuild
new file mode 100644
index 000000000000..e75aa557f773
--- /dev/null
+++ b/dev-ml/ocamlify/ocamlify-0.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlify/ocamlify-0.0.1.ebuild,v 1.1 2012/03/27 22:50:27 aballier Exp $
+
+EAPI=3
+
+OASIS_NO_DEBUG=1
+
+inherit oasis
+
+DESCRIPTION="OCamlify allows to create OCaml source code by including whole file into OCaml string or string list"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocamlify"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/379/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+IUSE=""
+
+DOCS=( "README.txt" "AUTHORS.txt" )