summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2006-02-04 22:25:39 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2006-02-04 22:25:39 +0000
commitd3b1a9ae008b4e32fa6a8697366cb466548a90d1 (patch)
treea5991f8995fef52afaea1256c56f97b1a49bbdc9 /dev-ml
parentmove to unstable (diff)
downloadhistorical-d3b1a9ae008b4e32fa6a8697366cb466548a90d1.tar.gz
historical-d3b1a9ae008b4e32fa6a8697366cb466548a90d1.tar.bz2
historical-d3b1a9ae008b4e32fa6a8697366cb466548a90d1.zip
Fix mistake of putting straight into stable
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlgraph/ChangeLog8
-rw-r--r--dev-ml/ocamlgraph/Manifest6
-rw-r--r--dev-ml/ocamlgraph/files/digest-ocamlgraph-0.811
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild36
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-0.95.ebuild4
5 files changed, 50 insertions, 5 deletions
diff --git a/dev-ml/ocamlgraph/ChangeLog b/dev-ml/ocamlgraph/ChangeLog
index 1bb90032f0fe..dbca8b40b304 100644
--- a/dev-ml/ocamlgraph/ChangeLog
+++ b/dev-ml/ocamlgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlgraph
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.2 2006/02/04 17:09:05 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.3 2006/02/04 22:25:39 mattam Exp $
+
+*ocamlgraph-0.81 (04 Feb 2006)
+
+ 04 Feb 2006; Matthieu Sozeau <mattam@gentoo.org> +ocamlgraph-0.81.ebuild,
+ ocamlgraph-0.95.ebuild:
+ Mark 0.95 ~ as per policy, resurect 0.81.
*ocamlgraph-0.95 (04 Feb 2006)
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
index 770b06ca7034..a11965df4440 100644
--- a/dev-ml/ocamlgraph/Manifest
+++ b/dev-ml/ocamlgraph/Manifest
@@ -1,4 +1,6 @@
-MD5 ada3d03fb7735c9f6454cdde0387964b ocamlgraph-0.95.ebuild 751
-MD5 54a72b46255359561266c4f67a0f51e8 ChangeLog 614
+MD5 1dd13a2ff89fd1f71204fbd8fbfa4944 ocamlgraph-0.95.ebuild 753
+MD5 a95671f2957b60fffe153322389ab6f6 ocamlgraph-0.81.ebuild 751
+MD5 1f4607ae8a5ee240600be0413ecff83d ChangeLog 793
MD5 648a541494aceee26dbcfd76164f37ea metadata.xml 157
+MD5 ba513d22f4e8a7de7b3ab289a6a668fc files/digest-ocamlgraph-0.81 66
MD5 1c00d30d6b944b907dd2f32768bbc346 files/digest-ocamlgraph-0.95 66
diff --git a/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.81 b/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.81
new file mode 100644
index 000000000000..fdc0b11ea639
--- /dev/null
+++ b/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.81
@@ -0,0 +1 @@
+MD5 c9592cd99502fd84cee90ca336701635 ocamlgraph-0.81.tar.gz 97467
diff --git a/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild b/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild
new file mode 100644
index 000000000000..8a00b5935f7b
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild,v 1.3 2006/02/04 22:25:39 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlgraph/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlgraph/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+DEPEND=">=dev-lang/ocaml-3.08
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ if use doc;
+ then
+ emake doc
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ make install-findlib || die
+
+ dodoc README COPYING CREDITS FAQ CHANGES
+ if use doc;
+ then
+ dohtml doc/*
+ fi
+}
diff --git a/dev-ml/ocamlgraph/ocamlgraph-0.95.ebuild b/dev-ml/ocamlgraph/ocamlgraph-0.95.ebuild
index 3ae3d451c8a6..fd7cbb8017d6 100644
--- a/dev-ml/ocamlgraph/ocamlgraph-0.95.ebuild
+++ b/dev-ml/ocamlgraph/ocamlgraph-0.95.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.95.ebuild,v 1.1 2006/02/04 17:09:05 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.95.ebuild,v 1.2 2006/02/04 22:25:39 mattam Exp $
inherit findlib
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.lri.fr/~filliatr/ocamlgraph/"
SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlgraph/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="~x86 ~ppc"
DEPEND=">=dev-lang/ocaml-3.08
doc? ( dev-tex/hevea dev-ml/ocamlweb )"
IUSE="doc"