summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-04-30 15:22:03 +0000
committerTorsten Veller <tove@gentoo.org>2008-04-30 15:22:03 +0000
commit184c0cd82fff64c55d94768522b8f33ab82569c7 (patch)
tree3a3d70e03a3092e955f57a328f9cf7b3378c50d8 /dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild
parentStable on ppc wrt bug 217638 (diff)
downloadhistorical-184c0cd82fff64c55d94768522b8f33ab82569c7.tar.gz
historical-184c0cd82fff64c55d94768522b8f33ab82569c7.tar.bz2
historical-184c0cd82fff64c55d94768522b8f33ab82569c7.zip
Add dev-perl/module-build to DEPEND (#216395)
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild')
-rw-r--r--dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild b/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild
index 238cd4bb1b21..c2deb2dc9152 100644
--- a/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild
+++ b/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild,v 1.6 2007/11/10 14:33:19 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Snowball-Swedish/Snowball-Swedish-1.2.ebuild,v 1.7 2008/04/30 15:22:03 tove Exp $
inherit perl-module multilib
@@ -15,7 +15,9 @@ IUSE=""
SRC_TEST="do"
-DEPEND="dev-lang/perl"
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ dev-perl/module-build"
src_install() {
perl-module_src_install
@@ -26,10 +28,10 @@ src_install() {
eval `perl '-V:archname'`
myarch=${archname}
- if [ -f ${D}/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/stemmer.pl ]; then
+ if [ -f "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/stemmer.pl ]; then
mv \
- ${D}/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/stemmer.pl \
- ${D}/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/se-stemmer.pl
+ "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/stemmer.pl \
+ "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${perl_version}/Lingua/Stem/Snowball/se-stemmer.pl
fi
}