summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-08-30 17:03:14 +0000
committerTorsten Veller <tove@gentoo.org>2011-08-30 17:03:14 +0000
commitedd05d9d3031258b25693498b8965611ee46aaf9 (patch)
tree0801ec2eed11ee621ad590444e8fe191cbf72c82 /dev-perl/WWW-Mechanize/WWW-Mechanize-1.700.0.ebuild
parentFix for CVE-2011-2910. see Bug #379293 (diff)
downloadhistorical-edd05d9d3031258b25693498b8965611ee46aaf9.tar.gz
historical-edd05d9d3031258b25693498b8965611ee46aaf9.tar.bz2
historical-edd05d9d3031258b25693498b8965611ee46aaf9.zip
[bump] dev-perl/WWW-Mechanize-1.700.0
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/WWW-Mechanize/WWW-Mechanize-1.700.0.ebuild')
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.700.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.700.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.700.0.ebuild
new file mode 100644
index 000000000000..b823b104724d
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.700.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.700.0.ebuild,v 1.1 2011/08/30 17:03:14 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JESSE
+MODULE_VERSION=1.70
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-perl/IO-Socket-SSL
+ || (
+ ( >dev-perl/libwww-perl-6 dev-perl/HTML-Form )
+ <dev-perl/libwww-perl-6
+ )
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/PadWalker
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle
+ dev-perl/HTTP-Server-Simple
+ )"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"