summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-08-10 15:37:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-08-10 15:37:20 +0000
commit6e2aa059167f4df96406f9e18321a052e200c63b (patch)
treede608ad811249d7cfb4329225cddcb2d55037bb8 /dev-perl/WWW-Mechanize
parentRespect LDFLAGS wrt bug 332009. Thanks to Diego for report. Remove old. (diff)
downloadhistorical-6e2aa059167f4df96406f9e18321a052e200c63b.tar.gz
historical-6e2aa059167f4df96406f9e18321a052e200c63b.tar.bz2
historical-6e2aa059167f4df96406f9e18321a052e200c63b.zip
Version bump via perl-bump experimental tool.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog8
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.64.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index fc883ea2f7bc..4df3e4f5f8bc 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.69 2010/04/15 06:40:57 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.70 2010/08/10 15:37:20 robbat2 Exp $
+
+*WWW-Mechanize-1.64 (10 Aug 2010)
+
+ 10 Aug 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +WWW-Mechanize-1.64.ebuild:
+ Version bump via perl-bump experimental tool.
*WWW-Mechanize-1.62 (15 Apr 2010)
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.64.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.64.ebuild
new file mode 100644
index 000000000000..6ef0b07d57d3
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.64.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.64.ebuild,v 1.1 2010/08/10 15:37:20 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.829
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle )"
+# dev-perl/HTTP-Server-Simple )"
+
+# Remove test until the bug is fixed:
+# http://rt.cpan.org/Public/Bug/Display.html?id=41673
+src_prepare() {
+ mv "${S}"/t/cookies.t{,.disable} || die
+ sed -i "/cookies.t/d" "${S}/MANIFEST" || die
+ perl-module_src_prepare
+}