summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuval Yaari <yuval@gentoo.org>2008-04-29 00:39:52 +0000
committerYuval Yaari <yuval@gentoo.org>2008-04-29 00:39:52 +0000
commit1f16b4fef7192ce949a3cd40aae7c87f35d1b159 (patch)
tree7f44a06e8b350807d8a581fa6f579a919ad354ae /dev-perl/XML-LibXML
parentamd64 stable, bug #219638 (diff)
downloadhistorical-1f16b4fef7192ce949a3cd40aae7c87f35d1b159.tar.gz
historical-1f16b4fef7192ce949a3cd40aae7c87f35d1b159.tar.bz2
historical-1f16b4fef7192ce949a3cd40aae7c87f35d1b159.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-perl/XML-LibXML')
-rw-r--r--dev-perl/XML-LibXML/ChangeLog7
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.66.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-perl/XML-LibXML/ChangeLog b/dev-perl/XML-LibXML/ChangeLog
index efe06252c0e8..1b0b0d55ccf4 100644
--- a/dev-perl/XML-LibXML/ChangeLog
+++ b/dev-perl/XML-LibXML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/XML-LibXML
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.80 2008/03/19 02:29:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.81 2008/04/29 00:18:53 yuval Exp $
+
+*XML-LibXML-1.66 (29 Apr 2008)
+
+ 29 Apr 2008; Yuval Yaari <yuval@gentoo.org> +XML-LibXML-1.66.ebuild:
+ Version bump
19 Mar 2008; Jeroen Roovers <jer@gentoo.org> XML-LibXML-1.65.ebuild:
Stable for HPPA too.
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.66.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.66.ebuild
new file mode 100644
index 000000000000..0528dfc75c5c
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-1.66.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.66.ebuild,v 1.1 2008/04/29 00:18:53 yuval Exp $
+
+inherit perl-module eutils versionator
+
+MY_P="${PN}-$(delete_version_separator 2)"
+S=${WORKDIR}/$PN-$(get_version_component_range "1-2" $PV)
+
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
+HOMEPAGE="http://search.cpan.org/~pajas/"
+SRC_URI="mirror://cpan/authors/id/P/PA/PAJAS/${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-perl/XML-SAX-0.12
+ dev-perl/XML-LibXML-Common
+ >=dev-libs/libxml2-2.6.6
+ >=dev-perl/XML-NamespaceSupport-1.07
+ dev-lang/perl"
+
+SRC_TEST="do"
+
+# rac can't discern any difference between the build with or without
+# this, and if somebody wants to reactivate it, get it out of global
+# scope.
+#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
+mytargets="pure_install doc_install"
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+ perl -MXML::SAX \
+ -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
+}