summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-10-10 13:23:03 +0000
committerTorsten Veller <tove@gentoo.org>2009-10-10 13:23:03 +0000
commit75ba97e28694416d9da0bd7cecb5aeae12fa3ee2 (patch)
tree2d97883917c142ba9796d345a73c16cefb357df1 /dev-perl/XML-LibXML
parentInitial commit (#288326) (diff)
downloadhistorical-75ba97e28694416d9da0bd7cecb5aeae12fa3ee2.tar.gz
historical-75ba97e28694416d9da0bd7cecb5aeae12fa3ee2.tar.bz2
historical-75ba97e28694416d9da0bd7cecb5aeae12fa3ee2.zip
Version bump
Package-Manager: portage-2.2_rc44/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/XML-LibXML')
-rw-r--r--dev-perl/XML-LibXML/ChangeLog9
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.70.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-perl/XML-LibXML/ChangeLog b/dev-perl/XML-LibXML/ChangeLog
index d63e66ec5e82..75377bd6c840 100644
--- a/dev-perl/XML-LibXML/ChangeLog
+++ b/dev-perl/XML-LibXML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/XML-LibXML
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.92 2008/12/30 16:26:19 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.93 2009/10/10 13:21:12 tove Exp $
+
+*XML-LibXML-1.70 (10 Oct 2009)
+
+ 10 Oct 2009; Torsten Veller <tove@gentoo.org> +XML-LibXML-1.70.ebuild:
+ Version bump
30 Dec 2008; Torsten Veller <tove@gentoo.org> -XML-LibXML-1.65.ebuild,
-XML-LibXML-1.66.ebuild:
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.70.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.70.ebuild
new file mode 100644
index 000000000000..cafec8204e81
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-1.70.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.70.ebuild,v 1.1 2009/10/10 13:21:12 tove Exp $
+
+EAPI=2
+
+#inherit versionator
+#MY_P="${PN}-$(delete_version_separator 2)"
+#S=${WORKDIR}/$PN-$(get_version_component_range "1-2" $PV)
+MODULE_AUTHOR=PAJAS
+inherit perl-module
+
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-perl/XML-SAX-0.12
+ >=dev-libs/libxml2-2.6.21
+ >=dev-perl/XML-NamespaceSupport-1.07"
+RDEPEND="${DEPEND}
+ !dev-perl/XML-LibXML-Common"
+
+SRC_TEST="do"
+
+# rac can't discern any difference between the build with or without
+# this, and if somebody wants to reactivate it, get it out of global
+# scope.
+#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
+mytargets="pure_install doc_install"
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}