summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2004-03-14 11:30:10 +0000
committerMichael Cummings <mcummings@gentoo.org>2004-03-14 11:30:10 +0000
commitf6c30af6bc99d656b9364768a973555c4992a87d (patch)
tree2bc8412c651f1fd8e20d5a2cfa1c440f6b6e773c /dev-perl/libwww-perl
parentInitial import. Ebuild submitted by Ray Tsang <rayt@9pnet.com>, closing bug #... (diff)
downloadhistorical-f6c30af6bc99d656b9364768a973555c4992a87d.tar.gz
historical-f6c30af6bc99d656b9364768a973555c4992a87d.tar.bz2
historical-f6c30af6bc99d656b9364768a973555c4992a87d.zip
Overdue fix for bugs 36341 44259
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog9
-rw-r--r--dev-perl/libwww-perl/Manifest6
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.69-r2.ebuild20
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.76.ebuild20
4 files changed, 47 insertions, 8 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 190a6c1793c3..add922ed894b 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.24 2004/02/27 21:16:45 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.25 2004/03/14 11:30:10 mcummings Exp $
+
+ 14 Mar 2004; Michael Cummings <mcummings@gentoo.org>
+ libwww-perl-5.69-r2.ebuild, libwww-perl-5.76.ebuild:
+ Because test failures for libwww-perl are 99% due to external factors, I've
+ added a block to allow the merge to continue but to display a warning to the
+ user so that they are aware that the tests didn't pass, and to list some
+ factors involved.
27 Feb 2004; Michael Cummings <mcummings@gentoo.org>
libwww-perl-5.76.ebuild:
diff --git a/dev-perl/libwww-perl/Manifest b/dev-perl/libwww-perl/Manifest
index 2441246a8b24..e9760722d2ab 100644
--- a/dev-perl/libwww-perl/Manifest
+++ b/dev-perl/libwww-perl/Manifest
@@ -1,11 +1,11 @@
-MD5 ed081fcec41ec2bcb60f5d8961bf3b3f ChangeLog 3022
+MD5 0f17576688bb1dd60f89bf39a1d093c9 ChangeLog 3385
MD5 559ffcb6d9d4e15afc43f8847e748498 libwww-perl-5.64-r1.ebuild 857
MD5 1b5821d93a32ac8dd85306d45fefacab libwww-perl-5.64.ebuild 855
MD5 7d3d2d77af5000f657a205007245bfd8 libwww-perl-5.68.ebuild 859
MD5 27c93e4ae7daafb0a485145b95c18a89 libwww-perl-5.69-r1.ebuild 896
-MD5 bc43cebe625e5d429794c5fdf06879d1 libwww-perl-5.69-r2.ebuild 850
+MD5 d7d6b0ce54398d9872d355cbd4d805d1 libwww-perl-5.69-r2.ebuild 1406
MD5 9300164fe8274f974740334519997bf3 libwww-perl-5.69.ebuild 861
-MD5 4cee6ddef59f3dc714df8dfacd76da2e libwww-perl-5.76.ebuild 837
+MD5 7b431397cb437881f09fb7a036fed8ac libwww-perl-5.76.ebuild 1392
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
MD5 a672dd749bc524ce5d83135e3a3bc987 files/digest-libwww-perl-5.64 68
MD5 a672dd749bc524ce5d83135e3a3bc987 files/digest-libwww-perl-5.64-r1 68
diff --git a/dev-perl/libwww-perl/libwww-perl-5.69-r2.ebuild b/dev-perl/libwww-perl/libwww-perl-5.69-r2.ebuild
index 74154648005c..2ddb9e5e726c 100644
--- a/dev-perl/libwww-perl/libwww-perl-5.69-r2.ebuild
+++ b/dev-perl/libwww-perl/libwww-perl-5.69-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.69-r2.ebuild,v 1.4 2004/02/22 20:45:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.69-r2.ebuild,v 1.5 2004/03/14 11:30:10 mcummings Exp $
inherit perl-module
@@ -24,5 +24,21 @@ mydoc="TODO"
src_compile() {
yes "" | perl Makefile.PL ${myconf} \
PREFIX=${D}/usr INSTALLDIRS=vendor
- perl-module_src_test || die
+ perl-module_src_test || export TEST_WARN="1"
+}
+
+pkg_postinst() {
+ if [ "${TEST_WARN}" == "1" ]; then
+ echo ""
+ eerror "Not all of libwww-perl's internal tests passed. This"
+ eerror "is generally caused by a misoconfigured network setting"
+ eerror "and not by a problem with libwww-perl itself. Some "
+ eerror "factors include network connectivity, proxies, firewalls,"
+ eerror "and bad /etc/hosts files, to name a few. If you "
+ eerror "have trouble using libwww-perl, please contact us at"
+ eerror "http://bugs.gentoo.org/"
+ echo ""
+ sleep 5
+ fi
+ perl-module_pkg_postinst
}
diff --git a/dev-perl/libwww-perl/libwww-perl-5.76.ebuild b/dev-perl/libwww-perl/libwww-perl-5.76.ebuild
index c9b1e381096c..1b63a71fb58b 100644
--- a/dev-perl/libwww-perl/libwww-perl-5.76.ebuild
+++ b/dev-perl/libwww-perl/libwww-perl-5.76.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.76.ebuild,v 1.4 2004/02/27 21:16:46 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.76.ebuild,v 1.5 2004/03/14 11:30:10 mcummings Exp $
inherit perl-module
@@ -22,5 +22,21 @@ newdepend ">=dev-perl/libnet-1.0703
src_compile() {
yes "" | perl Makefile.PL ${myconf} \
PREFIX=${D}/usr INSTALLDIRS=vendor
- perl-module_src_test || die
+ perl-module_src_test || export TEST_WARN="1"
+}
+
+pkg_postinst() {
+ if [ "${TEST_WARN}" == "1" ]; then
+ echo ""
+ eerror "Not all of libwww-perl's internal tests passed. This"
+ eerror "is generally caused by a misoconfigured network setting"
+ eerror "and not by a problem with libwww-perl itself. Some "
+ eerror "factors include network connectivity, proxies, firewalls,"
+ eerror "and bad /etc/hosts files, to name a few. If you "
+ eerror "have trouble using libwww-perl, please contact us at"
+ eerror "http://bugs.gentoo.org/"
+ echo ""
+ sleep 5
+ fi
+ perl-module_pkg_postinst
}