summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-11 21:05:51 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-11 21:05:51 +0000
commit4a860ad00d545c5c4a8d90b4dc399631f68d91f5 (patch)
treeabdad4b9ac65fb96dfa4e910b3c214a8981282b5 /dev-php/PEAR-Log
parentalpha/ia64/sparc/x86 stable (diff)
downloadhistorical-4a860ad00d545c5c4a8d90b4dc399631f68d91f5.tar.gz
historical-4a860ad00d545c5c4a8d90b4dc399631f68d91f5.tar.bz2
historical-4a860ad00d545c5c4a8d90b4dc399631f68d91f5.zip
Version bump, from the php overlay
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/ChangeLog7
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.10.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-php/PEAR-Log/ChangeLog b/dev-php/PEAR-Log/ChangeLog
index 86f6d7e4d567..d3d1d3903928 100644
--- a/dev-php/PEAR-Log/ChangeLog
+++ b/dev-php/PEAR-Log/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-Log
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/ChangeLog,v 1.80 2008/02/10 14:39:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/ChangeLog,v 1.81 2008/02/11 20:56:40 armin76 Exp $
+
+*PEAR-Log-1.10.0 (11 Feb 2008)
+
+ 11 Feb 2008; Raúl Porcel <armin76@gentoo.org> +PEAR-Log-1.10.0.ebuild:
+ Version bump, from the php overlay
10 Feb 2008; Raúl Porcel <armin76@gentoo.org> PEAR-Log-1.9.14.ebuild:
alpha/ia64/sparc stable wrt #208313
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.10.0.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.10.0.ebuild
new file mode 100644
index 000000000000..52451fd9695a
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.10.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/PEAR-Log-1.10.0.ebuild,v 1.1 2008/02/11 20:56:40 armin76 Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="The Log framework provides an abstracted logging system.
+It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal targets."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-Mail
+ >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
+
+pkg_postinst() {
+ has_php
+ if ! use minimal && ! built_with_use --missing true =${PHP_PKG} sqlite ; then
+ elog "${PN} can optionally use ${PHP_PKG} sqlite features."
+ elog "If you want those, recompile ${PHP_PKG} with this flag in USE."
+ fi
+}