summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2007-08-17 15:38:24 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2007-08-17 15:38:24 +0000
commitc430949dbe66600aa070ecb84e491e42e1f35d90 (patch)
tree2276e105351697876f419973b56240c4e14ac4f8 /dev-php/PEAR-Mail_Mime
parentNew ebuild, dependency for >=PEAR-Mail_Mime-1.5.2, thanks to Jakub Moc <jakub... (diff)
downloadhistorical-c430949dbe66600aa070ecb84e491e42e1f35d90.tar.gz
historical-c430949dbe66600aa070ecb84e491e42e1f35d90.tar.bz2
historical-c430949dbe66600aa070ecb84e491e42e1f35d90.zip
version bump wrt bug 158633, thanks to Jakub Moc; introducing new dependency on new package PEAR-Mail_mimeDecode and as such dropping all keywords except ~x86/~amd64
Package-Manager: portage-2.1.2.11
Diffstat (limited to 'dev-php/PEAR-Mail_Mime')
-rw-r--r--dev-php/PEAR-Mail_Mime/ChangeLog13
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.5.2.ebuild23
-rw-r--r--dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch74
-rw-r--r--dev-php/PEAR-Mail_Mime/files/digest-PEAR-Mail_Mime-1.5.23
4 files changed, 111 insertions, 2 deletions
diff --git a/dev-php/PEAR-Mail_Mime/ChangeLog b/dev-php/PEAR-Mail_Mime/ChangeLog
index b265698264af..0089126c22e9 100644
--- a/dev-php/PEAR-Mail_Mime/ChangeLog
+++ b/dev-php/PEAR-Mail_Mime/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-php/PEAR-Mail_Mime
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Mail_Mime/ChangeLog,v 1.44 2006/05/21 01:00:19 chtekk Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Mail_Mime/ChangeLog,v 1.45 2007/08/17 15:38:24 hoffie Exp $
+
+*PEAR-Mail_Mime-1.5.2 (17 Aug 2007)
+
+ 17 Aug 2007; Christian Hoffmann <hoffie@gentoo.org>
+ +files/1.5.2-php-pass-by-reference-fix.patch,
+ +PEAR-Mail_Mime-1.5.2.ebuild:
+ version bump wrt bug 158633, thanks to Jakub Moc; introducing new dependency
+ on new package PEAR-Mail_mimeDecode and as such dropping all keywords except
+ ~x86/~amd64
21 May 2006; Luca Longinotti <chtekk@gentoo.org>
-PEAR-Mail_Mime-1.2.1-r1.ebuild, -PEAR-Mail_Mime-1.3.0.ebuild,
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.5.2.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.5.2.ebuild
new file mode 100644
index 000000000000..7a417e10a25f
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.5.2.ebuild,v 1.1 2007/08/17 15:38:24 hoffie Exp $
+
+inherit php-pear-r1 eutils
+
+DESCRIPTION="Provides classes to deal with creation and manipulation of mime messages"
+
+LICENSE="PHP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-php/PEAR-PEAR-1.6.0"
+PDEPEND="dev-php/PEAR-Mail_mimeDecode"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # see Bug 125451; http://pear.php.net/bugs/bug.php?id=5333
+ epatch "${FILESDIR}"/1.5.2-php-pass-by-reference-fix.patch
+}
diff --git a/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch
new file mode 100644
index 000000000000..b18e4c642514
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch
@@ -0,0 +1,74 @@
+--- mime.php.orig 2007-08-16 12:16:47.000000000 +0200
++++ mime.php 2007-08-16 12:25:07.000000000 +0200
+@@ -376,7 +376,7 @@
+ * @return string contents of $file_name
+ * @access private
+ */
+- function &_file2str($file_name)
++ function _file2str($file_name)
+ {
+ if (!is_readable($file_name)) {
+ $err = PEAR::raiseError('File is not readable ' . $file_name);
+@@ -413,7 +413,7 @@
+ * @return object The text mimePart object
+ * @access private
+ */
+- function &_addTextPart(&$obj, $text)
++ function _addTextPart(&$obj, $text)
+ {
+ $params['content_type'] = 'text/plain';
+ $params['encoding'] = $this->_build_params['text_encoding'];
+@@ -437,7 +437,7 @@
+ * @return object The html mimePart object
+ * @access private
+ */
+- function &_addHtmlPart(&$obj)
++ function _addHtmlPart(&$obj)
+ {
+ $params['content_type'] = 'text/html';
+ $params['encoding'] = $this->_build_params['html_encoding'];
+@@ -459,7 +459,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addMixedPart()
++ function _addMixedPart()
+ {
+ $params = array();
+ $params['content_type'] = 'multipart/mixed';
+@@ -480,7 +480,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addAlternativePart(&$obj)
++ function _addAlternativePart(&$obj)
+ {
+ $params['content_type'] = 'multipart/alternative';
+ if (is_object($obj)) {
+@@ -502,7 +502,7 @@
+ * @return object The multipart/mixed mimePart object
+ * @access private
+ */
+- function &_addRelatedPart(&$obj)
++ function _addRelatedPart(&$obj)
+ {
+ $params['content_type'] = 'multipart/related';
+ if (is_object($obj)) {
+@@ -523,7 +523,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addHtmlImagePart(&$obj, $value)
++ function _addHtmlImagePart(&$obj, $value)
+ {
+ $params['content_type'] = $value['c_type'];
+ $params['encoding'] = 'base64';
+@@ -546,7 +546,7 @@
+ * @return object The image mimePart object
+ * @access private
+ */
+- function &_addAttachmentPart(&$obj, $value)
++ function _addAttachmentPart(&$obj, $value)
+ {
+ $params['dfilename'] = $value['name'];
+ $params['encoding'] = $value['encoding'];
diff --git a/dev-php/PEAR-Mail_Mime/files/digest-PEAR-Mail_Mime-1.5.2 b/dev-php/PEAR-Mail_Mime/files/digest-PEAR-Mail_Mime-1.5.2
new file mode 100644
index 000000000000..ab89b3787899
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/files/digest-PEAR-Mail_Mime-1.5.2
@@ -0,0 +1,3 @@
+MD5 30b931f620d880782ee8d5e454b51fdf Mail_Mime-1.5.2.tgz 22176
+RMD160 5956bc5fdca9eb9a084f92275eada90f5147d196 Mail_Mime-1.5.2.tgz 22176
+SHA256 5b17e1ffb417011fbd34ce35dd8f9a88adb66a710122af599a75f5a203f847cb Mail_Mime-1.5.2.tgz 22176