summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-03 18:46:33 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-03 18:46:33 +0000
commit1664b2238f5e728873827708a7417d38ec7c0f6c (patch)
tree23dabd7ddd51b87ebe74fe6bfe0145b54eb7599c /dev-python/Numeric
parentfix dep logic (diff)
downloadhistorical-1664b2238f5e728873827708a7417d38ec7c0f6c.tar.gz
historical-1664b2238f5e728873827708a7417d38ec7c0f6c.tar.bz2
historical-1664b2238f5e728873827708a7417d38ec7c0f6c.zip
version bump
Diffstat (limited to 'dev-python/Numeric')
-rw-r--r--dev-python/Numeric/ChangeLog9
-rw-r--r--dev-python/Numeric/Numeric-23.0.ebuild37
-rw-r--r--dev-python/Numeric/files/digest-Numeric-23.01
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/Numeric/ChangeLog b/dev-python/Numeric/ChangeLog
index 7ec866350014..26f9d330fd64 100644
--- a/dev-python/Numeric/ChangeLog
+++ b/dev-python/Numeric/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for dev-python/Numeric
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/ChangeLog,v 1.8 2003/02/12 06:30:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/ChangeLog,v 1.9 2003/04/03 18:46:33 liquidx Exp $
-*Numeric-22.0 (17 Dec 20020
+*Numeric-23.0 (03 Apr 2003)
+
+ 03 Apr 2003; Alastair Tse <liquidx@gentoo.org> Numeric-23.0.ebuild:
+ version bump
+
+*Numeric-22.0 (17 Dec 2002)
17 Dec 2002; B.Lauwers <blauwers@gentoo.org> :
Version bump.
diff --git a/dev-python/Numeric/Numeric-23.0.ebuild b/dev-python/Numeric/Numeric-23.0.ebuild
new file mode 100644
index 000000000000..7f67bc5eeacb
--- /dev/null
+++ b/dev-python/Numeric/Numeric-23.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-23.0.ebuild,v 1.1 2003/04/03 18:46:33 liquidx Exp $
+
+IUSE=""
+
+inherit distutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="numerical python module"
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="as-is"
+
+src_install() {
+
+ distutils_src_install
+
+ #grab python verision so ebuild doesn't depend on it
+ local pv
+ pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+
+ #Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${pv}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+
diff --git a/dev-python/Numeric/files/digest-Numeric-23.0 b/dev-python/Numeric/files/digest-Numeric-23.0
new file mode 100644
index 000000000000..cc2aa609b30d
--- /dev/null
+++ b/dev-python/Numeric/files/digest-Numeric-23.0
@@ -0,0 +1 @@
+MD5 2f8c3c5d0703ce12f55f04f43d1a9ab3 Numeric-23.0.tar.gz 723250