summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-03 19:02:32 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-03 19:02:32 +0000
commitc0032d6274155a64c4ee8b276cc6580dc3082ec3 (patch)
tree55a8e027538f8a7c8068e6d2bc48266318730ca0 /dev-python/Numeric
parentchanged hardcoded src to mirror://Gentoo (diff)
downloadhistorical-c0032d6274155a64c4ee8b276cc6580dc3082ec3.tar.gz
historical-c0032d6274155a64c4ee8b276cc6580dc3082ec3.tar.bz2
historical-c0032d6274155a64c4ee8b276cc6580dc3082ec3.zip
cleanup
Diffstat (limited to 'dev-python/Numeric')
-rw-r--r--dev-python/Numeric/Numeric-19.0.0.ebuild30
-rw-r--r--dev-python/Numeric/Numeric-20.3.ebuild45
-rw-r--r--dev-python/Numeric/Numeric-21.0.ebuild45
-rw-r--r--dev-python/Numeric/files/digest-Numeric-19.0.01
-rw-r--r--dev-python/Numeric/files/digest-Numeric-20.31
-rw-r--r--dev-python/Numeric/files/digest-Numeric-21.01
6 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/Numeric/Numeric-19.0.0.ebuild b/dev-python/Numeric/Numeric-19.0.0.ebuild
deleted file mode 100644
index f0736afc132d..000000000000
--- a/dev-python/Numeric/Numeric-19.0.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-19.0.0.ebuild,v 1.15 2003/02/13 11:32:24 vapier Exp $
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="numerical python module"
-SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
-HOMEPAGE="http://www.pfdubois.com/numpy/"
-
-DEPEND="virtual/python"
-
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
-LICENSE="as-is"
-
-PYTHON_VERSION=
-
-src_compile() {
- python setup_all.py build || die
-}
-
-src_install() {
- python setup_all.py install --prefix=${D}/usr || die
-
- dodoc MANIFEST PKG-INFO README*
-
- #need to automate the python version in the path
- mv Demo/NumTut ${D}/usr/lib/python2.0/site-packages/
-}
diff --git a/dev-python/Numeric/Numeric-20.3.ebuild b/dev-python/Numeric/Numeric-20.3.ebuild
deleted file mode 100644
index e00e824603cc..000000000000
--- a/dev-python/Numeric/Numeric-20.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-20.3.ebuild,v 1.12 2003/02/13 11:32:28 vapier Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="numerical python module"
-SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
-HOMEPAGE="http://www.pfdubois.com/numpy/"
-
-# 2.1 gave sandbox violations see #21
-DEPEND=">=dev-lang/python-2.2"
-
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
-LICENSE="as-is"
-
-src_compile() {
-
-#The ebuild as is uses a small local version of BLAS and LAPACK provided
-#by the Numeric package. If I ever get ATLAS and LAPACK ebuilds finished,
-#we'll need to edit (sed) setup.py to use the real libraries.
-
- python setup_all.py build || die
-
-}
-
-src_install() {
-
- python setup_all.py install --prefix=${D}/usr || die
-
- dodoc MANIFEST PKG-INFO README
-
-#grab python verision so ebuild doesn't depend on it
- local pv
- pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
-
-#Numerical Tutorial is nice for testing and learning
- insinto /usr/lib/python${pv}/site-packages/NumTut
- doins Demo/NumTut/*
-
-}
-
-
-
-
diff --git a/dev-python/Numeric/Numeric-21.0.ebuild b/dev-python/Numeric/Numeric-21.0.ebuild
deleted file mode 100644
index 0eb4870bf4b9..000000000000
--- a/dev-python/Numeric/Numeric-21.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-21.0.ebuild,v 1.12 2003/02/13 11:32:32 vapier Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="numerical python module"
-SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
-HOMEPAGE="http://www.pfdubois.com/numpy/"
-
-# 2.1 gave sandbox violations see #21
-DEPEND=">=dev-lang/python-2.2"
-
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
-LICENSE="as-is"
-
-src_compile() {
-
-#The ebuild as is uses a small local version of BLAS and LAPACK provided
-#by the Numeric package. If I ever get ATLAS and LAPACK ebuilds finished,
-#we'll need to edit (sed) setup.py to use the real libraries.
-
- python setup.py build || die
-
-}
-
-src_install() {
-
- python setup.py install --prefix=${D}/usr || die
-
- dodoc MANIFEST PKG-INFO README
-
-#grab python verision so ebuild doesn't depend on it
- local pv
- pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
-
-#Numerical Tutorial is nice for testing and learning
- insinto /usr/lib/python${pv}/site-packages/NumTut
- doins Demo/NumTut/*
-
-}
-
-
-
-
diff --git a/dev-python/Numeric/files/digest-Numeric-19.0.0 b/dev-python/Numeric/files/digest-Numeric-19.0.0
deleted file mode 100644
index b8516456f05e..000000000000
--- a/dev-python/Numeric/files/digest-Numeric-19.0.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e2f46242b61f21d8bdaf1a48b6cbf7e8 Numeric-19.0.0.tar.gz 588704
diff --git a/dev-python/Numeric/files/digest-Numeric-20.3 b/dev-python/Numeric/files/digest-Numeric-20.3
deleted file mode 100644
index 9a219098fec7..000000000000
--- a/dev-python/Numeric/files/digest-Numeric-20.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 99c832837d203ca8492343ff2a072e42 Numeric-20.3.tar.gz 711012
diff --git a/dev-python/Numeric/files/digest-Numeric-21.0 b/dev-python/Numeric/files/digest-Numeric-21.0
deleted file mode 100644
index 6838a3e193a9..000000000000
--- a/dev-python/Numeric/files/digest-Numeric-21.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0684989aa6dfa4eba616ca7e36c524fd Numeric-21.0.tar.gz 718118