summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-01 01:31:17 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-01 01:31:17 +0000
commit95beb16a5dc85e8dac508fd345684a65652315b6 (patch)
treef55f6ec0af27e180865fc3ce2460bcc96fc4da7e /dev-python/bsddb3/bsddb3-3.4.0-r1.ebuild
parentNew version from CPAN; added missing DEPEND (diff)
downloadhistorical-95beb16a5dc85e8dac508fd345684a65652315b6.tar.gz
historical-95beb16a5dc85e8dac508fd345684a65652315b6.tar.bz2
historical-95beb16a5dc85e8dac508fd345684a65652315b6.zip
db4 compat fixes
Diffstat (limited to 'dev-python/bsddb3/bsddb3-3.4.0-r1.ebuild')
-rw-r--r--dev-python/bsddb3/bsddb3-3.4.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/bsddb3/bsddb3-3.4.0-r1.ebuild b/dev-python/bsddb3/bsddb3-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..387e7c0f0f1e
--- /dev/null
+++ b/dev-python/bsddb3/bsddb3-3.4.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-3.4.0-r1.ebuild,v 1.1 2003/06/01 01:31:09 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="Python bindings for BerkelyDB"
+HOMEPAGE="http://pybsddb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pybsddb/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/python
+ =sys-libs/db-3*"
+
+S="${WORKDIR}/${P}"
+
+DOCS="README.txt TODO.txt"
+
+src_unpack() {
+ unpack ${A}
+ einfo "Applying ${P}-db3.patch"
+ cd ${S}; patch -p0 < ${FILESDIR}/${P}-db3.patch
+}
+
+src_install() {
+ distutils_src_install
+ dohtml docs/*
+}
+