summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:04:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:04:44 +0000
commitd8350dac981d64d767867dcef45a39e6079149ae (patch)
tree0f6827e14b85599bad87609b98ce871d4a9f8f1f /dev-python/bsddb3
parentUse -j1 for make. Bug #279962. (diff)
downloadhistorical-d8350dac981d64d767867dcef45a39e6079149ae.tar.gz
historical-d8350dac981d64d767867dcef45a39e6079149ae.tar.bz2
historical-d8350dac981d64d767867dcef45a39e6079149ae.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-13874-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/ChangeLog8
-rw-r--r--dev-python/bsddb3/bsddb3-4.7.6-r1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/bsddb3/ChangeLog b/dev-python/bsddb3/ChangeLog
index 604696416e77..45833b4bcbf4 100644
--- a/dev-python/bsddb3/ChangeLog
+++ b/dev-python/bsddb3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/bsddb3
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.37 2009/07/17 18:12:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.38 2009/08/01 23:01:02 arfrever Exp $
+
+*bsddb3-4.7.6-r1 (01 Aug 2009)
+
+ 01 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +bsddb3-4.7.6-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
17 Jul 2009; nixnut <nixnut@gentoo.org> ChangeLog:
ppc stable #274180
diff --git a/dev-python/bsddb3/bsddb3-4.7.6-r1.ebuild b/dev-python/bsddb3/bsddb3-4.7.6-r1.ebuild
new file mode 100644
index 000000000000..ed2a0c9cb5fc
--- /dev/null
+++ b/dev-python/bsddb3/bsddb3-4.7.6-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.7.6-r1.ebuild,v 1.1 2009/08/01 23:01:02 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit db-use distutils multilib
+
+DESCRIPTION="Python bindings for BerkeleyDB"
+HOMEPAGE="http://www.jcea.es/programacion/pybsddb.htm"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=sys-libs/db-4.6"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_compile() {
+ local DB_VER
+ if has_version sys-libs/db:4.7; then
+ DB_VER="4.7"
+ else
+ DB_VER="4.6"
+ fi
+
+ sed -i \
+ -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
+ setup2.py setup3.py || die "sed failed"
+
+ distutils_src_compile \
+ "--berkeley-db=/usr" \
+ "--berkeley-db-incdir=$(db_includedir ${DB_VER})" \
+ "--berkeley-db-libdir=/usr/$(get_libdir)"
+
+ if use doc; then
+ mkdir html
+ sphinx-build docs html || die "building docs failed"
+ fi
+}
+
+src_install() {
+ DOCS="TODO.txt"
+ distutils_src_install
+
+ distutils_python_version
+ rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tests"
+
+ use doc && dohtml -r html/*
+}
+
+src_test() {
+ tests() {
+ rm -fr /tmp/z-Berkeley_DB
+ python_set_build_dir_symlink
+ "${python}" test.py
+ }
+ python_execute_function tests
+}