summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-24 23:32:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-24 23:32:11 +0000
commitda91d3247efcb0b33bfce978b49790b540db4801 (patch)
tree00737cefb11c8d6a1796c142b216a10d74ffd828 /dev-python/cython
parentFixed bug 349423 (diff)
downloadhistorical-da91d3247efcb0b33bfce978b49790b540db4801.tar.gz
historical-da91d3247efcb0b33bfce978b49790b540db4801.tar.bz2
historical-da91d3247efcb0b33bfce978b49790b540db4801.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/cython-0.14.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/cython/cython-0.14.ebuild b/dev-python/cython/cython-0.14.ebuild
deleted file mode 100644
index 84a3d3f3932b..000000000000
--- a/dev-python/cython/cython-0.14.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.14.ebuild,v 1.2 2010/12/23 11:19:40 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit distutils
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/.}"
-
-DESCRIPTION="The Cython compiler for writing C extensions for the Python language"
-HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
-SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="README.txt ToDo.txt USAGE.txt"
-PYTHON_MODNAME="Cython cython.py pyximport"
-
-src_test() {
- testing() {
- rm -fr BUILD
- "$(PYTHON)" runtests.py -vv
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- # "-A c" is for ignoring of "Doc/primes.c".
- dohtml -A c -r Doc/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r Demos/* || die "Installation of examples failed"
- fi
-}