summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-11 07:34:40 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-11 07:34:40 +0000
commit4927f4ee4b1934afdd3e99cbb9d32628f42f4b45 (patch)
treecbaddf2ad388516ce4d69d4bf52e61a82b9ca377 /dev-python/fabric/fabric-1.5.1.ebuild
parentStable on amd64, wrt bug #451062 (diff)
downloadhistorical-4927f4ee4b1934afdd3e99cbb9d32628f42f4b45.tar.gz
historical-4927f4ee4b1934afdd3e99cbb9d32628f42f4b45.tar.bz2
historical-4927f4ee4b1934afdd3e99cbb9d32628f42f4b45.zip
Bump for #451226
Package-Manager: portage-2.2.0_alpha150/cvs/Linux x86_64
Diffstat (limited to 'dev-python/fabric/fabric-1.5.1.ebuild')
-rw-r--r--dev-python/fabric/fabric-1.5.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/fabric/fabric-1.5.1.ebuild b/dev-python/fabric/fabric-1.5.1.ebuild
new file mode 100644
index 000000000000..0d4853382475
--- /dev/null
+++ b/dev-python/fabric/fabric-1.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.5.1.ebuild,v 1.1 2013/01/11 07:34:27 patrick Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython *-pypy-*"
+DISTUTILS_SRC_TEST="nosetests"
+
+# Requires multiprocessing package from py2.6+
+PYTHON_TESTS_RESTRICTED_ABIS="2.5"
+
+inherit distutils
+
+MY_PN="Fabric"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Fabric is a simple, Pythonic tool for remote execution and deployment."
+HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/paramiko"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( <dev-python/fudge-1.0 )"
+
+S="${WORKDIR}/${MY_P}"
+PYTHON_MODULES="fabfile fabric"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ emake -C docs html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/
+ fi
+}