summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-10 13:13:14 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-10 13:13:14 +0000
commit57259f43db6b9f0b0494b149937c7daecec58be1 (patch)
treed2ed7f1546983276935bbd17f5b67aee15c4b951 /dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
parentVersion bump. (diff)
downloadhistorical-57259f43db6b9f0b0494b149937c7daecec58be1.tar.gz
historical-57259f43db6b9f0b0494b149937c7daecec58be1.tar.bz2
historical-57259f43db6b9f0b0494b149937c7daecec58be1.zip
revbump, migrate -> distutils-r1, rm old, patch to fix tests
Package-Manager: portage-2.1.11.63/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild')
-rw-r--r--dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..329e8bcd8852
--- /dev/null
+++ b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild,v 1.1 2013/06/10 13:12:38 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="Flask-Themes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Infrastructure for theming support in Flask applications."
+HOMEPAGE="http://packages.python.org/Flask-Themes/ http://pypi.python.org/pypi/Flask-Themes"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]
+ virtual/python-json[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/fixtests.patch )
+
+python_test() {
+ PYTHONPATH=.:tests nosetests || die "Tests failed under ${EPYTHON}"
+}