summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-29 11:25:36 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-29 11:25:36 +0000
commitc1f5846714d6eea705277b2ae25278d73d5e650d (patch)
treef4a4261d40cfd758eab77687447f194caf5e18ac /dev-python/mod_python
parentupdated for Apache2 (diff)
downloadhistorical-c1f5846714d6eea705277b2ae25278d73d5e650d.tar.gz
historical-c1f5846714d6eea705277b2ae25278d73d5e650d.tar.bz2
historical-c1f5846714d6eea705277b2ae25278d73d5e650d.zip
updated for Apache2
Diffstat (limited to 'dev-python/mod_python')
-rw-r--r--dev-python/mod_python/ChangeLog6
-rw-r--r--dev-python/mod_python/files/16_mod_python.conf40
-rw-r--r--dev-python/mod_python/files/digest-mod_python-3.0.0_beta41
-rw-r--r--dev-python/mod_python/files/mod_python-3.0.0_beta4-destdir.diff29
-rw-r--r--dev-python/mod_python/mod_python-2.7.8.ebuild5
-rw-r--r--dev-python/mod_python/mod_python-3.0.0_beta4.ebuild37
6 files changed, 114 insertions, 4 deletions
diff --git a/dev-python/mod_python/ChangeLog b/dev-python/mod_python/ChangeLog
index 942d17bd3aa5..7f222f1d2a0c 100644
--- a/dev-python/mod_python/ChangeLog
+++ b/dev-python/mod_python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mod_python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.2 2002/11/27 16:59:16 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.3 2002/11/29 11:25:36 woodchip Exp $
+
+*mod_python-3.0.0_beta4 (29 Nov 2002)
+
+ 29 Nov 2002; Donny Davies <woodchip@gentoo.org> : Updated for Apache2.
*mod_python-2.7.8 (21 Oct 2002)
diff --git a/dev-python/mod_python/files/16_mod_python.conf b/dev-python/mod_python/files/16_mod_python.conf
new file mode 100644
index 000000000000..b678da4f188d
--- /dev/null
+++ b/dev-python/mod_python/files/16_mod_python.conf
@@ -0,0 +1,40 @@
+<IfDefine PYTHON>
+ <IfModule !mod_python.c>
+ LoadModule python_module extramodules/mod_python.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_python.c>
+#
+# Mod_python is a module that embeds the Python language interpreter
+# within the server, allowing Apache handlers to be written in Python.
+#
+
+# This will cause files beneath /home/httpd/htdocs with the extension .spam
+# to be handled by the Python script /home/httpd/htdocs/eggs.py
+#
+#<Directory /home/httpd/htdocs>
+# <IfModule mod_mime.c>
+# AddHandler python-program .spam
+# </IfModule>
+# PythonHandler eggs
+#</Directory>
+
+# This will cause all requests to the /python heirachy of your
+# webserver to be handled by the python script /path/to/myhandler.py
+#
+#<Location /python>
+# SetHandler python-program
+# PythonPath "sys.path + ['/path/to']"
+# PythonHandler myhandler
+#</Location>
+
+# This will cause all requests to the /python heirachy of your
+# webserver to be handled by mod_python's Publisher handler
+#
+#<Location /python>
+# SetHandler python-program
+# PythonHandler mod_python.publisher
+#</Location>
+
+</IfModule>
diff --git a/dev-python/mod_python/files/digest-mod_python-3.0.0_beta4 b/dev-python/mod_python/files/digest-mod_python-3.0.0_beta4
new file mode 100644
index 000000000000..8b7911290d67
--- /dev/null
+++ b/dev-python/mod_python/files/digest-mod_python-3.0.0_beta4
@@ -0,0 +1 @@
+MD5 3846e3dc817cb8aca702e9d66ff2ce73 mod_python-3.0.0-BETA4.tgz 211306
diff --git a/dev-python/mod_python/files/mod_python-3.0.0_beta4-destdir.diff b/dev-python/mod_python/files/mod_python-3.0.0_beta4-destdir.diff
new file mode 100644
index 000000000000..1b040ca9962f
--- /dev/null
+++ b/dev-python/mod_python/files/mod_python-3.0.0_beta4-destdir.diff
@@ -0,0 +1,29 @@
+--- Makefile.in.orig 2002-11-27 10:51:39.000000000 -0500
++++ Makefile.in 2002-11-27 10:52:16.000000000 -0500
+@@ -92,7 +92,7 @@
+ @echo
+ @echo "Performing DSO installation."
+ @echo
+- $(INSTALL) src/mod_python.so $(LIBEXECDIR)
++ $(INSTALL) src/mod_python.so $(DESTDIR)$(LIBEXECDIR)
+ @$(MAKE) install_py_lib
+ @echo
+ @echo "Now don't forget to edit your main config and add"
+@@ -102,13 +102,13 @@
+ @echo
+
+ install_py_lib:
+- $(INSTALL) -d $(PY_STD_LIB)/site-packages/mod_python
++ $(INSTALL) -d $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
+ @for f in `ls lib/python/mod_python/*.py`; \
+ do \
+- $(INSTALL) $$f $(PY_STD_LIB)/site-packages/mod_python; \
++ $(INSTALL) $$f $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python; \
+ done
+- ${PYTHON_BIN} $(PY_STD_LIB)/compileall.py $(PY_STD_LIB)/site-packages/mod_python
+- ${PYTHON_BIN} -O $(PY_STD_LIB)/compileall.py $(PY_STD_LIB)/site-packages/mod_python
++ ${PYTHON_BIN} $(PY_STD_LIB)/compileall.py $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
++ ${PYTHON_BIN} -O $(PY_STD_LIB)/compileall.py $(DESTDIR)$(PY_STD_LIB)/site-packages/mod_python
+
+ clean:
+ cd src && $(MAKE) clean
diff --git a/dev-python/mod_python/mod_python-2.7.8.ebuild b/dev-python/mod_python/mod_python-2.7.8.ebuild
index 931bb23fe004..f2746e55a074 100644
--- a/dev-python/mod_python/mod_python-2.7.8.ebuild
+++ b/dev-python/mod_python/mod_python-2.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.8.ebuild,v 1.3 2002/11/17 09:13:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.8.ebuild,v 1.4 2002/11/29 11:25:36 woodchip Exp $
DESCRIPTION="Python module for Apache"
SRC_URI="http://www.modpython.org/dist/${P}.tgz"
@@ -10,8 +10,7 @@ LICENSE="AS-IS"
KEYWORDS="~x86"
SLOT="0"
-DEPEND=">=net-www/apache-1.3.26-r2
- dev-lang/python"
+DEPEND="=net-www/apache-1* dev-lang/python"
src_unpack() {
unpack ${A}
diff --git a/dev-python/mod_python/mod_python-3.0.0_beta4.ebuild b/dev-python/mod_python/mod_python-3.0.0_beta4.ebuild
new file mode 100644
index 000000000000..eec8cad33f19
--- /dev/null
+++ b/dev-python/mod_python/mod_python-3.0.0_beta4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.0.0_beta4.ebuild,v 1.1 2002/11/29 11:25:36 woodchip Exp $
+
+DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
+HOMEPAGE="http://www.modpython.org/"
+
+NEWP="`echo ${P} | sed -e 's|_beta|-BETA|'`"
+S=${WORKDIR}/${NEWP}
+SRC_URI="http://www.apache.org/dist/httpd/modpython/dev/${NEWP}.tgz"
+DEPEND="dev-lang/python =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ patch -p0 <${FILESDIR}/mod_python-3.0.0_beta4-destdir.diff || die
+}
+
+src_compile() {
+ ./configure --with-apxs=/usr/sbin/apxs2 || die
+ make OPT="`apxs2 -q CFLAGS` -fPIC" || die
+}
+
+src_install() {
+ dodir /usr/lib/{apache2,apache2-extramodules}
+ make install DESTDIR=${D} || die
+ mv ${D}/usr/lib/apache2/${PN}.so ${D}/usr/lib/apache2-extramodules
+ rm -rf ${D}/usr/lib/apache2
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/16_mod_python.conf
+ dodoc ${FILESDIR}/16_mod_python.conf README NEWS CREDITS COPYRIGHT
+ dohtml doc-html/*
+}