summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-25 11:40:55 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-25 11:40:55 +0000
commitf29c771a3fb38ac17980aa1a85cb5ad882eb307b (patch)
tree35d668d3cf9d2c1d6735f63989a042e23ac50e78 /dev-python/optcomplete/optcomplete-1.2.ebuild
parentVersion bump (diff)
downloadhistorical-f29c771a3fb38ac17980aa1a85cb5ad882eb307b.tar.gz
historical-f29c771a3fb38ac17980aa1a85cb5ad882eb307b.tar.bz2
historical-f29c771a3fb38ac17980aa1a85cb5ad882eb307b.zip
İnitial ebuild for optcomplete.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-gentoo-r1 x86_64
Diffstat (limited to 'dev-python/optcomplete/optcomplete-1.2.ebuild')
-rw-r--r--dev-python/optcomplete/optcomplete-1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/optcomplete/optcomplete-1.2.ebuild b/dev-python/optcomplete/optcomplete-1.2.ebuild
new file mode 100644
index 000000000000..93bec45c783a
--- /dev/null
+++ b/dev-python/optcomplete/optcomplete-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/optcomplete/optcomplete-1.2.ebuild,v 1.1 2008/06/25 11:40:55 hawking Exp $
+
+inherit distutils
+
+DESCRIPTION="Shell completion self-generator for python"
+HOMEPAGE="http://furius.ca/optcomplete/"
+SRC_URI="http://furius.ca/downloads/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="CHANGES"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins bin/* || die "doins failed"
+ fi
+}