summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-05 17:05:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-05 17:05:11 +0000
commit9018f42a324eef4e80fda8f8a55370ba8e3a3c06 (patch)
tree8fcbd5ed0ddc4fd32ceac695b9f861e8ed99d1c5 /dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild
parentMove png to mirrors (diff)
downloadhistorical-9018f42a324eef4e80fda8f8a55370ba8e3a3c06.tar.gz
historical-9018f42a324eef4e80fda8f8a55370ba8e3a3c06.tar.bz2
historical-9018f42a324eef4e80fda8f8a55370ba8e3a3c06.zip
Reintroduced avoid testing thanks to Arfrever
Package-Manager: portage-2.1.10.10/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild')
-rw-r--r--dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild b/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild
new file mode 100644
index 000000000000..3aa09e73fcc7
--- /dev/null
+++ b/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygraphviz/pygraphviz-1.1-r1.ebuild,v 1.1 2011/08/05 17:05:11 bicatali Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="http://networkx.lanl.gov/pygraphviz/ http://pypi.python.org/pypi/pygraphviz"
+SRC_URI="http://networkx.lanl.gov/download/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples"
+
+RDEPEND=">=media-gfx/graphviz-2.12"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-1.0-setup.py.patch
+ epatch "${FILESDIR}"/${P}-avoid_tests.patch
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" -c "import sys; sys.path.insert(0, '$(ls -d build-${PYTHON_ABI}/lib.*)'); import pygraphviz.tests; pygraphviz.tests.run()"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/${PN}/tests"
+ }
+ python_execute_function -q delete_tests
+}