summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-23 02:30:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-23 02:30:16 +0000
commit1db8effa499116cd53ae87ec02ff67f7bbefb920 (patch)
treee0f2affdd6120a8dd69af08a0c21afd28785a5e4 /dev-python/python-twitter/python-twitter-0.6.ebuild
parentVersion bump. Upstream has included pre-generated manpages again. (diff)
downloadhistorical-1db8effa499116cd53ae87ec02ff67f7bbefb920.tar.gz
historical-1db8effa499116cd53ae87ec02ff67f7bbefb920.tar.bz2
historical-1db8effa499116cd53ae87ec02ff67f7bbefb920.zip
Set SUPPORT_PYTHON_ABIS. Add src_test(). Add "examples" USE flag.
Package-Manager: portage-14874-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/python-twitter/python-twitter-0.6.ebuild')
-rw-r--r--dev-python/python-twitter/python-twitter-0.6.ebuild39
1 files changed, 32 insertions, 7 deletions
diff --git a/dev-python/python-twitter/python-twitter-0.6.ebuild b/dev-python/python-twitter/python-twitter-0.6.ebuild
index ae40a8171e22..223efd0dff32 100644
--- a/dev-python/python-twitter/python-twitter-0.6.ebuild
+++ b/dev-python/python-twitter/python-twitter-0.6.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/python-twitter-0.6.ebuild,v 1.3 2009/10/30 20:39:54 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/python-twitter-0.6.ebuild,v 1.4 2009/11/23 02:30:15 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -11,15 +14,37 @@ SRC_URI="http://python-twitter.googlecode.com/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="examples"
RDEPEND="dev-python/simplejson"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="CHANGES README"
+PYTHON_MODNAME="twitter.py"
-pkg_postinst() {
- python_version
- python_mod_optimize $(python_get_sitedir)/python_twitter-${PV}-py${PYVER}.egg/
+src_prepare() {
+ distutils_src_prepare
+
+ # Delete internal copy of simplejson.
+ rm -fr simplejson
}
-pkg_postrm() {
- python_mod_cleanup
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" twitter_test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml doc/twitter.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
}