summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-10 12:04:53 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-10 12:04:53 +0000
commita00ea42c71914b673f3a191871bffd05beead7c9 (patch)
tree9b611f8285b8519fe8e0fb2b8b32c40ac0d49ac0 /dev-python/requests-oauthlib/requests-oauthlib-0.4.0.ebuild
parentVersion bump to 1.8.0. (diff)
downloadhistorical-a00ea42c71914b673f3a191871bffd05beead7c9.tar.gz
historical-a00ea42c71914b673f3a191871bffd05beead7c9.tar.bz2
historical-a00ea42c71914b673f3a191871bffd05beead7c9.zip
bump; test phase updated with related patch sourced from upstream
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/requests-oauthlib/requests-oauthlib-0.4.0.ebuild')
-rw-r--r--dev-python/requests-oauthlib/requests-oauthlib-0.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-0.4.0.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-0.4.0.ebuild
new file mode 100644
index 000000000000..df3c26d79ff1
--- /dev/null
+++ b/dev-python/requests-oauthlib/requests-oauthlib-0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests-oauthlib/requests-oauthlib-0.4.0.ebuild,v 1.1 2014/04/10 12:04:26 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="https://github.com/requests/requests-oauthlib"
+SRC_URI="https://github.com/requests/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.4.2[${PYTHON_USEDEP}]
+"
+PATCHES=( "${FILESDIR}"/${P}-expires_at.patch )
+
+python_test() {
+ # https://github.com/requests/requests-oauthlib/issues/112
+ sed -e 's:test_add_token:_&:' -i tests/test_oauth2_session.py || die
+ esetup.py test
+}