summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-07 10:26:40 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-07 10:26:40 +0000
commitd5b568025a91a71fd9055467aca2b2c8335bc82f (patch)
tree08c33eabe1a594247a2d9e39ec4ef79926ebadb4 /dev-python/wxPython
parentversion bump (diff)
downloadhistorical-d5b568025a91a71fd9055467aca2b2c8335bc82f.tar.gz
historical-d5b568025a91a71fd9055467aca2b2c8335bc82f.tar.bz2
historical-d5b568025a91a71fd9055467aca2b2c8335bc82f.zip
add support for non-unicode wxGTK
Diffstat (limited to 'dev-python/wxPython')
-rw-r--r--dev-python/wxPython/ChangeLog6
-rw-r--r--dev-python/wxPython/Manifest6
-rw-r--r--dev-python/wxPython/wxPython-2.4.0.6.ebuild4
-rw-r--r--dev-python/wxPython/wxPython-2.4.0.7.ebuild4
4 files changed, 12 insertions, 8 deletions
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 23398a982a03..399852bb6d81 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.24 2003/04/27 00:39:49 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.25 2003/05/07 10:26:30 liquidx Exp $
+
+ 07 May 2003; Alastair Tse <liquidx@gentoo.org> wxPython-2.4.0.6.ebuild,
+ wxPython-2.4.0.7.ebuild:
+ Detect non-unicode wxGTK
*wxPython-2.4.0.7 (27 Apr 2003)
diff --git a/dev-python/wxPython/Manifest b/dev-python/wxPython/Manifest
index 668ac01c8caf..b6a78a42d00d 100644
--- a/dev-python/wxPython/Manifest
+++ b/dev-python/wxPython/Manifest
@@ -1,7 +1,7 @@
-MD5 0db925d43b17c9063d78039ab2524bb2 ChangeLog 3934
-MD5 e29c99600abf4b1c42f19f922a1698b0 wxPython-2.4.0.7.ebuild 3081
+MD5 c3a35373c7631510c8fa8e34429a80d0 ChangeLog 4063
+MD5 c8166d9061cd5fc20046a91b6d3c1e5c wxPython-2.4.0.7.ebuild 3118
MD5 0938f70998dfcb709f808d7121c2305e wxPython-2.4.0.2.ebuild 2320
-MD5 5a53e701e96b8a776302be442f45b47b wxPython-2.4.0.6.ebuild 3081
+MD5 2e17b3357727895ad65eeacb3b61ceef wxPython-2.4.0.6.ebuild 3118
MD5 88f72c81ee2c594876b3bddc9e14bb72 files/digest-wxPython-2.4.0.7 73
MD5 da22eb14f789d103f8802058263951da files/digest-wxPython-2.4.0.2 73
MD5 b9e15002ddba12f3653a8cfdc638a0cc files/wxPython-2.3.3.1-noglcanvas.diff 3207
diff --git a/dev-python/wxPython/wxPython-2.4.0.6.ebuild b/dev-python/wxPython/wxPython-2.4.0.6.ebuild
index 0864ab5bcaa2..a190e70e1900 100644
--- a/dev-python/wxPython/wxPython-2.4.0.6.ebuild
+++ b/dev-python/wxPython/wxPython-2.4.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.6.ebuild,v 1.3 2003/03/26 11:49:26 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.6.ebuild,v 1.4 2003/05/07 10:26:30 liquidx Exp $
IUSE="opengl gtk2"
@@ -26,7 +26,7 @@ pkg_setup() {
# make sure if you want gtk2, you have wxGTK with gtk2, and vice versa
if [ -n "`use gtk2`" ]; then
- if [ ! -f "/usr/bin/wxgtk2u-2.4-config" ]; then
+ if [ ! -f "/usr/bin/wxgtk2u-2.4-config" -a ! -f "/usr/bin/wxgtk2-2.4-config" ]; then
eerror "You need x11-libs/wxGTK compiled with GTK+2 support."
eerror "Either emerge wxGTK with 'gtk2' in your USE flags or"
eerror "emerge wxPython without 'gtk2' in your USE flags."
diff --git a/dev-python/wxPython/wxPython-2.4.0.7.ebuild b/dev-python/wxPython/wxPython-2.4.0.7.ebuild
index c7ca5102a4cc..a7e4c7c19fa8 100644
--- a/dev-python/wxPython/wxPython-2.4.0.7.ebuild
+++ b/dev-python/wxPython/wxPython-2.4.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.7.ebuild,v 1.1 2003/04/27 00:39:49 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.7.ebuild,v 1.2 2003/05/07 10:26:30 liquidx Exp $
IUSE="opengl gtk2"
@@ -26,7 +26,7 @@ pkg_setup() {
# make sure if you want gtk2, you have wxGTK with gtk2, and vice versa
if [ -n "`use gtk2`" ]; then
- if [ ! -f "/usr/bin/wxgtk2u-2.4-config" ]; then
+ if [ ! -f "/usr/bin/wxgtk2u-2.4-config" -a ! -f "/usr/bin/wxgtk2-2.4-config" ]; then
eerror "You need x11-libs/wxGTK compiled with GTK+2 support."
eerror "Either emerge wxGTK with 'gtk2' in your USE flags or"
eerror "emerge wxPython without 'gtk2' in your USE flags."