summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-05-26 18:47:48 +0000
committerMarien Zwart <marienz@gentoo.org>2006-05-26 18:47:48 +0000
commit134b9389205399f725d2359462fcb710e626fe89 (patch)
tree65248b9423acc14dc1fe9f08ae23f4b492ffbc70 /dev-python
parentStable on ppc64 (diff)
downloadhistorical-134b9389205399f725d2359462fcb710e626fe89.tar.gz
historical-134b9389205399f725d2359462fcb710e626fe89.tar.bz2
historical-134b9389205399f725d2359462fcb710e626fe89.zip
Version bump.
Package-Manager: portage-2.1_rc2-r3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted-conch/ChangeLog8
-rw-r--r--dev-python/twisted-conch/files/digest-twisted-conch-0.7.03
-rw-r--r--dev-python/twisted-conch/twisted-conch-0.7.0.ebuild22
-rw-r--r--dev-python/twisted-lore/ChangeLog7
-rw-r--r--dev-python/twisted-lore/files/digest-twisted-lore-0.2.03
-rw-r--r--dev-python/twisted-lore/twisted-lore-0.2.0.ebuild14
-rw-r--r--dev-python/twisted-mail/ChangeLog7
-rw-r--r--dev-python/twisted-mail/files/digest-twisted-mail-0.3.03
-rw-r--r--dev-python/twisted-mail/twisted-mail-0.3.0.ebuild14
-rw-r--r--dev-python/twisted-names/ChangeLog8
-rw-r--r--dev-python/twisted-names/files/digest-twisted-names-0.3.03
-rw-r--r--dev-python/twisted-names/twisted-names-0.3.0.ebuild13
-rw-r--r--dev-python/twisted-news/ChangeLog7
-rw-r--r--dev-python/twisted-news/files/digest-twisted-news-0.2.03
-rw-r--r--dev-python/twisted-news/twisted-news-0.2.0.ebuild14
-rw-r--r--dev-python/twisted-runner/ChangeLog8
-rw-r--r--dev-python/twisted-runner/files/digest-twisted-runner-0.2.03
-rw-r--r--dev-python/twisted-runner/twisted-runner-0.2.0.ebuild15
-rw-r--r--dev-python/twisted-web/ChangeLog7
-rw-r--r--dev-python/twisted-web/files/digest-twisted-web-0.6.03
-rw-r--r--dev-python/twisted-web/twisted-web-0.6.0.ebuild19
-rw-r--r--dev-python/twisted-words/ChangeLog8
-rw-r--r--dev-python/twisted-words/files/digest-twisted-words-0.4.03
-rw-r--r--dev-python/twisted-words/twisted-words-0.4.0.ebuild14
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/files/digest-twisted-2.2.02
-rw-r--r--dev-python/twisted/files/digest-twisted-2.4.03
-rw-r--r--dev-python/twisted/twisted-2.4.0.ebuild110
28 files changed, 322 insertions, 9 deletions
diff --git a/dev-python/twisted-conch/ChangeLog b/dev-python/twisted-conch/ChangeLog
index 731b608fbfeb..2762012d89ea 100644
--- a/dev-python/twisted-conch/ChangeLog
+++ b/dev-python/twisted-conch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-conch
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.12 2006/05/26 17:32:38 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/ChangeLog,v 1.13 2006/05/26 18:42:56 marienz Exp $
+
+*twisted-conch-0.7.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org>
+ +twisted-conch-0.7.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-conch-0.5.0-r1.ebuild, twisted-conch-0.6.0.ebuild:
diff --git a/dev-python/twisted-conch/files/digest-twisted-conch-0.7.0 b/dev-python/twisted-conch/files/digest-twisted-conch-0.7.0
new file mode 100644
index 000000000000..3d8253a1008e
--- /dev/null
+++ b/dev-python/twisted-conch/files/digest-twisted-conch-0.7.0
@@ -0,0 +1,3 @@
+MD5 0236162d53cf7f34ed341d9179e7783b TwistedConch-0.7.0.tar.bz2 127274
+RMD160 d9334942b887af86a7a19dcf6e15d5f3b54b558e TwistedConch-0.7.0.tar.bz2 127274
+SHA256 d5e41c90f0319a4bed48725626ee46b9f33a0744cf060b64184248623ca112c0 TwistedConch-0.7.0.tar.bz2 127274
diff --git a/dev-python/twisted-conch/twisted-conch-0.7.0.ebuild b/dev-python/twisted-conch/twisted-conch-0.7.0.ebuild
new file mode 100644
index 000000000000..ee48caac1543
--- /dev/null
+++ b/dev-python/twisted-conch/twisted-conch-0.7.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-conch/twisted-conch-0.7.0.ebuild,v 1.1 2006/05/26 18:42:56 marienz Exp $
+
+MY_PACKAGE=Conch
+
+inherit twisted eutils
+
+DESCRIPTION="Twisted SSHv2 implementation."
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4
+ >=dev-python/pycrypto-1.9_alpha6"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.6.0-root-skip.patch"
+}
diff --git a/dev-python/twisted-lore/ChangeLog b/dev-python/twisted-lore/ChangeLog
index 0adecc9e15f7..83ee9a13300d 100644
--- a/dev-python/twisted-lore/ChangeLog
+++ b/dev-python/twisted-lore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-lore
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.9 2006/05/26 17:37:11 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/ChangeLog,v 1.10 2006/05/26 18:43:37 marienz Exp $
+
+*twisted-lore-0.2.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org> +twisted-lore-0.2.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-lore-0.1.0-r1.ebuild:
diff --git a/dev-python/twisted-lore/files/digest-twisted-lore-0.2.0 b/dev-python/twisted-lore/files/digest-twisted-lore-0.2.0
new file mode 100644
index 000000000000..9e12a6edb2fc
--- /dev/null
+++ b/dev-python/twisted-lore/files/digest-twisted-lore-0.2.0
@@ -0,0 +1,3 @@
+MD5 213569a86fc3d8558605e2847e6378b0 TwistedLore-0.2.0.tar.bz2 61194
+RMD160 b6b6390af3e945657817d3e059bf377580e7df35 TwistedLore-0.2.0.tar.bz2 61194
+SHA256 7b4cac320680dc1f5c84b93021b7eaf7cd646ca63e3556c7360f53e0f3e3acf9 TwistedLore-0.2.0.tar.bz2 61194
diff --git a/dev-python/twisted-lore/twisted-lore-0.2.0.ebuild b/dev-python/twisted-lore/twisted-lore-0.2.0.ebuild
new file mode 100644
index 000000000000..b4e8576a4495
--- /dev/null
+++ b/dev-python/twisted-lore/twisted-lore-0.2.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-0.2.0.ebuild,v 1.1 2006/05/26 18:43:37 marienz Exp $
+
+MY_PACKAGE=Lore
+
+inherit twisted
+
+DESCRIPTION="Twisted documentation system"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4
+ dev-python/twisted-web"
diff --git a/dev-python/twisted-mail/ChangeLog b/dev-python/twisted-mail/ChangeLog
index 521762cc01d0..75db1f022b02 100644
--- a/dev-python/twisted-mail/ChangeLog
+++ b/dev-python/twisted-mail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-mail
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.12 2006/05/26 17:38:45 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/ChangeLog,v 1.13 2006/05/26 18:44:19 marienz Exp $
+
+*twisted-mail-0.3.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org> +twisted-mail-0.3.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-mail-0.1.0-r1.ebuild, twisted-mail-0.2.0.ebuild:
diff --git a/dev-python/twisted-mail/files/digest-twisted-mail-0.3.0 b/dev-python/twisted-mail/files/digest-twisted-mail-0.3.0
new file mode 100644
index 000000000000..8730d8586253
--- /dev/null
+++ b/dev-python/twisted-mail/files/digest-twisted-mail-0.3.0
@@ -0,0 +1,3 @@
+MD5 33667938b399ee5513c59b5d4087294b TwistedMail-0.3.0.tar.bz2 115148
+RMD160 beff8b02d2820ae232db2016a0a431092fb64ff4 TwistedMail-0.3.0.tar.bz2 115148
+SHA256 4e06390acdf7fa3706fe71cb2ae7ba0147a0a01cfebb9dd16ae01d72e573ae1b TwistedMail-0.3.0.tar.bz2 115148
diff --git a/dev-python/twisted-mail/twisted-mail-0.3.0.ebuild b/dev-python/twisted-mail/twisted-mail-0.3.0.ebuild
new file mode 100644
index 000000000000..e1a06f830ed2
--- /dev/null
+++ b/dev-python/twisted-mail/twisted-mail-0.3.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-mail/twisted-mail-0.3.0.ebuild,v 1.1 2006/05/26 18:44:19 marienz Exp $
+
+MY_PACKAGE=Mail
+
+inherit twisted
+
+DESCRIPTION="A Twisted Mail library, server and client."
+
+KEYWORDS="~alpha ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4
+ >=dev-python/twisted-names-0.2.0"
diff --git a/dev-python/twisted-names/ChangeLog b/dev-python/twisted-names/ChangeLog
index 7e6ba0992bf3..efbf8602372b 100644
--- a/dev-python/twisted-names/ChangeLog
+++ b/dev-python/twisted-names/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-names
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.10 2006/05/26 17:40:35 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/ChangeLog,v 1.11 2006/05/26 18:45:01 marienz Exp $
+
+*twisted-names-0.3.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org>
+ +twisted-names-0.3.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-names-0.1.0-r1.ebuild, twisted-names-0.2.0.ebuild:
diff --git a/dev-python/twisted-names/files/digest-twisted-names-0.3.0 b/dev-python/twisted-names/files/digest-twisted-names-0.3.0
new file mode 100644
index 000000000000..46bca2d1f940
--- /dev/null
+++ b/dev-python/twisted-names/files/digest-twisted-names-0.3.0
@@ -0,0 +1,3 @@
+MD5 5aa672d0e26718466351351e7bfcf22a TwistedNames-0.3.0.tar.bz2 29402
+RMD160 80abd4f6ea99aabbf5c563ead463466efa33706c TwistedNames-0.3.0.tar.bz2 29402
+SHA256 1351e16c1d5c03b8067b9d95cc6a9466a05a142b8b6e596da5c89db83e54819f TwistedNames-0.3.0.tar.bz2 29402
diff --git a/dev-python/twisted-names/twisted-names-0.3.0.ebuild b/dev-python/twisted-names/twisted-names-0.3.0.ebuild
new file mode 100644
index 000000000000..f793562421e3
--- /dev/null
+++ b/dev-python/twisted-names/twisted-names-0.3.0.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-names/twisted-names-0.3.0.ebuild,v 1.1 2006/05/26 18:45:01 marienz Exp $
+
+MY_PACKAGE=Names
+
+inherit twisted
+
+DESCRIPTION="A Twisted DNS implementation."
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4"
diff --git a/dev-python/twisted-news/ChangeLog b/dev-python/twisted-news/ChangeLog
index 399d6aaf59f1..9a1d06e1b867 100644
--- a/dev-python/twisted-news/ChangeLog
+++ b/dev-python/twisted-news/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-news
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.8 2006/05/26 17:42:06 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.9 2006/05/26 18:45:43 marienz Exp $
+
+*twisted-news-0.2.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org> +twisted-news-0.2.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-news-0.1.0-r1.ebuild:
diff --git a/dev-python/twisted-news/files/digest-twisted-news-0.2.0 b/dev-python/twisted-news/files/digest-twisted-news-0.2.0
new file mode 100644
index 000000000000..0f0ca7cf96ec
--- /dev/null
+++ b/dev-python/twisted-news/files/digest-twisted-news-0.2.0
@@ -0,0 +1,3 @@
+MD5 62a93645867bacad4a4ca4d45e9ce090 TwistedNews-0.2.0.tar.bz2 16811
+RMD160 50a33f3562c90a4023c44ca5a35960150dbac5f1 TwistedNews-0.2.0.tar.bz2 16811
+SHA256 158d30a3cd2a88bf2b8c127715b034dbe0f8dde1318e64c961c723d8ea1c77da TwistedNews-0.2.0.tar.bz2 16811
diff --git a/dev-python/twisted-news/twisted-news-0.2.0.ebuild b/dev-python/twisted-news/twisted-news-0.2.0.ebuild
new file mode 100644
index 000000000000..696e3e385c14
--- /dev/null
+++ b/dev-python/twisted-news/twisted-news-0.2.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-0.2.0.ebuild,v 1.1 2006/05/26 18:45:43 marienz Exp $
+
+MY_PACKAGE=News
+
+inherit twisted
+
+DESCRIPTION="Twisted News is an NNTP server and programming library."
+
+KEYWORDS="~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4
+ dev-python/twisted-mail"
diff --git a/dev-python/twisted-runner/ChangeLog b/dev-python/twisted-runner/ChangeLog
index bdfdf2bf7775..e865d519edb7 100644
--- a/dev-python/twisted-runner/ChangeLog
+++ b/dev-python/twisted-runner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-runner
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/ChangeLog,v 1.8 2006/05/26 17:45:20 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/ChangeLog,v 1.9 2006/05/26 18:46:24 marienz Exp $
+
+*twisted-runner-0.2.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org>
+ +twisted-runner-0.2.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-runner-0.1.0-r1.ebuild:
diff --git a/dev-python/twisted-runner/files/digest-twisted-runner-0.2.0 b/dev-python/twisted-runner/files/digest-twisted-runner-0.2.0
new file mode 100644
index 000000000000..408271707946
--- /dev/null
+++ b/dev-python/twisted-runner/files/digest-twisted-runner-0.2.0
@@ -0,0 +1,3 @@
+MD5 ec4677a59dd2643d50da0914b3a1df88 TwistedRunner-0.2.0.tar.bz2 8308
+RMD160 6e37efd6633592830a584478966e7aa552d4a451 TwistedRunner-0.2.0.tar.bz2 8308
+SHA256 7a8a56547cff8219181999887625651e94f87e0b3f65e2e52a36d9def497ef27 TwistedRunner-0.2.0.tar.bz2 8308
diff --git a/dev-python/twisted-runner/twisted-runner-0.2.0.ebuild b/dev-python/twisted-runner/twisted-runner-0.2.0.ebuild
new file mode 100644
index 000000000000..3d9ebee635b9
--- /dev/null
+++ b/dev-python/twisted-runner/twisted-runner-0.2.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-runner/twisted-runner-0.2.0.ebuild,v 1.1 2006/05/26 18:46:24 marienz Exp $
+
+MY_PACKAGE=Runner
+
+inherit twisted
+
+DESCRIPTION="Twisted Runner is a process management library and inetd replacement."
+
+KEYWORDS="~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4"
+
+PROVIDE="virtual/inetd"
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index 3b0d1935d7e7..0f0aa777425c 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted-web
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.14 2006/05/26 17:46:43 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.15 2006/05/26 18:47:06 marienz Exp $
+
+*twisted-web-0.6.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org> +twisted-web-0.6.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-web-0.5.0-r1.ebuild, twisted-web-0.5.0-r2.ebuild:
diff --git a/dev-python/twisted-web/files/digest-twisted-web-0.6.0 b/dev-python/twisted-web/files/digest-twisted-web-0.6.0
new file mode 100644
index 000000000000..b6ef47e32fb2
--- /dev/null
+++ b/dev-python/twisted-web/files/digest-twisted-web-0.6.0
@@ -0,0 +1,3 @@
+MD5 a681931d2eb747ca871ef71d8d1f5ff1 TwistedWeb-0.6.0.tar.bz2 263572
+RMD160 3884538b3d937365acbab06dbf44a7223ba019e0 TwistedWeb-0.6.0.tar.bz2 263572
+SHA256 db8cb87fd65f751a807fe22893145210235ce9fbc070e10fd827495f05babca6 TwistedWeb-0.6.0.tar.bz2 263572
diff --git a/dev-python/twisted-web/twisted-web-0.6.0.ebuild b/dev-python/twisted-web/twisted-web-0.6.0.ebuild
new file mode 100644
index 000000000000..a72d410fb815
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-0.6.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.6.0.ebuild,v 1.1 2006/05/26 18:47:06 marienz Exp $
+
+MY_PACKAGE=Web
+
+inherit twisted eutils
+
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.5.0-root-skip.patch"
+}
diff --git a/dev-python/twisted-words/ChangeLog b/dev-python/twisted-words/ChangeLog
index 755a612dd092..6d83ba621af3 100644
--- a/dev-python/twisted-words/ChangeLog
+++ b/dev-python/twisted-words/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-words
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.11 2006/05/26 17:51:06 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.12 2006/05/26 18:47:48 marienz Exp $
+
+*twisted-words-0.4.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org>
+ +twisted-words-0.4.0.ebuild:
+ Version bump.
26 May 2006; Marien Zwart <marienz@gentoo.org>
twisted-words-0.1.0-r1.ebuild, twisted-words-0.3.0.ebuild:
diff --git a/dev-python/twisted-words/files/digest-twisted-words-0.4.0 b/dev-python/twisted-words/files/digest-twisted-words-0.4.0
new file mode 100644
index 000000000000..a365ab2d22df
--- /dev/null
+++ b/dev-python/twisted-words/files/digest-twisted-words-0.4.0
@@ -0,0 +1,3 @@
+MD5 37d34da233aefe4a7a41b97bc9222b6a TwistedWords-0.4.0.tar.bz2 139966
+RMD160 2e327ef7ecc9a3650684639c1a22cb481a3ea8e5 TwistedWords-0.4.0.tar.bz2 139966
+SHA256 fba8135614723d9d8dbdbf9ab5b16ef2cc58a1c821eb456034fd357dbdb7fdb3 TwistedWords-0.4.0.tar.bz2 139966
diff --git a/dev-python/twisted-words/twisted-words-0.4.0.ebuild b/dev-python/twisted-words/twisted-words-0.4.0.ebuild
new file mode 100644
index 000000000000..75a8a5e3da9b
--- /dev/null
+++ b/dev-python/twisted-words/twisted-words-0.4.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-0.4.0.ebuild,v 1.1 2006/05/26 18:47:48 marienz Exp $
+
+MY_PACKAGE=Words
+
+inherit twisted
+
+DESCRIPTION="Twisted Words contains Instant Messaging implementations."
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4
+ dev-python/twisted-web"
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 2114db052721..7f8ecce42a9c 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.69 2006/05/25 14:09:20 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.70 2006/05/26 18:42:12 marienz Exp $
+
+*twisted-2.4.0 (26 May 2006)
+
+ 26 May 2006; Marien Zwart <marienz@gentoo.org> +twisted-2.4.0.ebuild:
+ Version bump.
25 May 2006; Michael Hanselmann <hansmi@gentoo.org> twisted-2.0.1.ebuild:
Stable on ppc.
diff --git a/dev-python/twisted/files/digest-twisted-2.2.0 b/dev-python/twisted/files/digest-twisted-2.2.0
index 7dfbc15cf5bb..12337b77cc2b 100644
--- a/dev-python/twisted/files/digest-twisted-2.2.0
+++ b/dev-python/twisted/files/digest-twisted-2.2.0
@@ -1 +1,3 @@
MD5 4a9305e69cdcf01a594c4fe1ea1efc05 Twisted-2.2.0.tar.bz2 1285316
+RMD160 c11353da93878721c8549a0594363b9d8ee38e12 Twisted-2.2.0.tar.bz2 1285316
+SHA256 537ec738c23ced2ec4a9b7f7124c2cd9bded1308331442ced0f3de7cd7562387 Twisted-2.2.0.tar.bz2 1285316
diff --git a/dev-python/twisted/files/digest-twisted-2.4.0 b/dev-python/twisted/files/digest-twisted-2.4.0
new file mode 100644
index 000000000000..8ffcaca36b46
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-2.4.0
@@ -0,0 +1,3 @@
+MD5 042a57f65fe919a9234047d7ce8c43f1 TwistedCore-2.4.0.tar.bz2 1213389
+RMD160 2ee341412675d2ef4582ae595adf49ce254eb88b TwistedCore-2.4.0.tar.bz2 1213389
+SHA256 114f8ecf2625916f6cd65099d4321243f2b56704dddb0c96b30f6b991db484d2 TwistedCore-2.4.0.tar.bz2 1213389
diff --git a/dev-python/twisted/twisted-2.4.0.ebuild b/dev-python/twisted/twisted-2.4.0.ebuild
new file mode 100644
index 000000000000..a522cd939b92
--- /dev/null
+++ b/dev-python/twisted/twisted-2.4.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.4.0.ebuild,v 1.1 2006/05/26 18:42:12 marienz Exp $
+
+inherit eutils distutils versionator
+
+MY_P=TwistedCore-${PV}
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Twisted/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="gtk serial crypt"
+
+DEPEND=">=dev-lang/python-2.3
+ >=net-zope/zopeinterface-3.0.1
+ serial? ( dev-python/pyserial )
+ crypt? ( >=dev-python/pyopenssl-0.5.1 )
+ gtk? ( >=dev-python/pygtk-1.99 )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CREDITS INSTALL NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Give a load-sensitive test a better chance of succeeding.
+ epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
+
+ # Pass valid arguments to "head" in the zsh completion function.
+ epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
+
+ # Remove a mostly-empty file with a syntax error ("???" placeholder)
+ rm twisted/test/stdio_test_halfclose.py
+}
+
+src_install() {
+ distutils_src_install
+
+ # get rid of this to prevent collision-protect from killing us. it
+ # is regenerated in pkg_postinst.
+ rm "${D}/usr/$(get_libdir)"/python*/site-packages/twisted/plugins/dropin.cache
+
+ # weird pattern to avoid installing the index.xhtml page
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ # workaround for a possible portage bug
+ mkdir -p "${D}/etc/conf.d/"
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+
+ # zsh completion
+ insinto /usr/share/zsh/site-functions/
+ doins twisted/python/_twisted_zsh_stub
+}
+
+update_plugin_cache() {
+ python_version
+ local tpath="${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/twisted"
+ # we have to remove the cache or removed plugins won't be removed
+ # from the cache (http://twistedmatrix.com/bugs/issue926)
+ [[ -e "${tpath}/plugins/dropin.cache" ]] && rm -f "${tpath}/plugins/dropin.cache"
+ if [[ -e "${tpath}/plugin.py" ]]; then
+ # twisted is still installed, update.
+ # we have to use getPlugIns here for <=twisted-2.0.1 compatibility
+ einfo "Regenerating plugin cache"
+ python -c "from twisted.plugin import IPlugin, getPlugIns;list(getPlugIns(IPlugin))"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ update_plugin_cache
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ update_plugin_cache
+}
+
+src_test() {
+ python_version
+
+ if has_version ">=dev-lang/python-2.3"; then
+ "${python}" setup.py install --root="${T}/tests" --no-compile || die
+ else
+ "${python}" setup.py install --root="${T}/tests" || die
+ fi
+
+ cd "${T}/tests/usr/$(get_libdir)/python${PYVER}/site-packages/" || die
+
+ # prevent it from pulling in plugins from already installed
+ # twisted packages
+ rm twisted/plugins/__init__.py || die
+
+ # an empty file doesn't work because the tests check for
+ # docstrings in all packages
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ PYTHONPATH=. "${T}"/tests/usr/bin/trial twisted || die "trial failed"
+ cd "${S}"
+ rm -rf "${T}/tests"
+}