summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-22 13:58:45 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-22 13:58:45 +0000
commit49565a3311cf69f486b97747ac9822eb6e5c5a60 (patch)
treeeb71370bc464168a7e4aa34ad21561995192d3e9 /dev-python
parentmerged into bitchx ebuild (diff)
downloadhistorical-49565a3311cf69f486b97747ac9822eb6e5c5a60.tar.gz
historical-49565a3311cf69f486b97747ac9822eb6e5c5a60.tar.bz2
historical-49565a3311cf69f486b97747ac9822eb6e5c5a60.zip
use USE=gnome to see if GNOME support really should be built
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python/files/digest-gnome-python-1.4.1-r11
-rw-r--r--dev-python/gnome-python/gnome-python-1.4.1-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/gnome-python/files/digest-gnome-python-1.4.1-r1 b/dev-python/gnome-python/files/digest-gnome-python-1.4.1-r1
new file mode 100644
index 000000000000..821fcc40a094
--- /dev/null
+++ b/dev-python/gnome-python/files/digest-gnome-python-1.4.1-r1
@@ -0,0 +1 @@
+MD5 52f8b5ef4cbdaba3c00c08e28702be69 gnome-python-1.4.1.tar.gz
diff --git a/dev-python/gnome-python/gnome-python-1.4.1-r1.ebuild b/dev-python/gnome-python/gnome-python-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..70b74c39d8ce
--- /dev/null
+++ b/dev-python/gnome-python/gnome-python-1.4.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.1-r1.ebuild,v 1.1 2001/09/22 13:58:45 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-python"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/latest/sources/"${A}
+HOMEPAGE="http://www.gnome.org"
+
+DEPEND="virtual/python
+ >=x11-libs/gtk+-1.2.6
+ >=media-libs/imlib-1.8.10
+ gnome? ( >=gnome-base/gnome-core-1.4.0 )
+ opengl? ( >=x11-libs/gtkglarea-1.2.2 )"
+
+src_compile() {
+
+ if [ -n "`use gnome`" ]
+ then
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
+ make || die
+ else
+ cd ${S}/pygtk
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
+ make || die
+ fi
+}
+
+src_install() {
+
+ if [ -n "`use gnome`" ]
+ then
+ cd ${S}/pygnome
+ make prefix=${D}/usr install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS MAPPING
+ dodoc README*
+
+ cd ${S}/pygnome
+ docinto pygnome
+ dodoc COPYING
+ else
+ cd ${S}/pygtk
+ make prefix=${D}/usr install || die
+ fi
+
+ cd ${S}/pygtk
+ docinto pygtk
+ dodoc AUTHORS COPYING ChangeLog NEWS MAPPING README
+}
+
+
+