summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-17 22:52:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-17 22:52:27 +0000
commit890914f3c2d186809d10cf2c12f2a8db5ca0b97b (patch)
tree9dde90a37be2f760e1bf2ad3d0856aea101db2c0 /dev-python
parentStable on amd64 wrt bug #351800 (diff)
downloadhistorical-890914f3c2d186809d10cf2c12f2a8db5ca0b97b.tar.gz
historical-890914f3c2d186809d10cf2c12f2a8db5ca0b97b.tar.bz2
historical-890914f3c2d186809d10cf2c12f2a8db5ca0b97b.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astng/astng-0.20.1.ebuild65
-rw-r--r--dev-python/astng/astng-0.20.2.ebuild60
2 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/astng/astng-0.20.1.ebuild b/dev-python/astng/astng-0.20.1.ebuild
deleted file mode 100644
index 4eea19550460..000000000000
--- a/dev-python/astng/astng-0.20.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.20.1.ebuild,v 1.5 2010/07/18 14:06:29 nixnut Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
-HOMEPAGE="http://www.logilab.org/projects/astng/ http://pypi.python.org/pypi/logilab-astng"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz http://pypi.python.org/packages/source/l/logilab-astng/logilab-${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ~ppc64 ~sparc x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.49.0"
-DEPEND="${RDEPEND}
- test? ( >=dev-python/egenix-mx-base-3.0.0 )"
-
-S="${WORKDIR}/logilab-${P}"
-
-PYTHON_MODNAME="logilab/astng"
-
-src_test() {
- testing() {
- local sdir="${T}/test/$(python_get_sitedir)"
-
- # This is a hack to make tests work without installing to the live
- # filesystem. We copy part of the logilab site-packages to a temporary
- # dir, install there, and run from there.
- mkdir -p "${sdir}/logilab" || die
- cp -r "$(python_get_sitedir)/logilab/common" "${sdir}/logilab" || die "copying logilab-common failed!"
-
- "$(PYTHON)" setup.py install --root="${T}/test" || die "test copy failed"
-
- # Pytest picks up tests relative to the current dir, so cd in.
- pushd "${sdir}/logilab/astng" > /dev/null || die
- PYTHONPATH="${sdir}" pytest -v || die "tests failed"
- popd > /dev/null
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- deletion_of_unneeded_files() {
- local sdir="${ED}$(python_get_sitedir)/logilab"
-
- # we need to remove this file because it collides with the one
- # from logilab-common (which we depend on).
- # Bug 111970 and bug 223025
- rm -f "${sdir}/__init__.py" || die
-
- # Remove unittests since they're just needed during build-time
- rm -fr "${sdir}/astng/test" || die
- }
- python_execute_function -q deletion_of_unneeded_files
-}
diff --git a/dev-python/astng/astng-0.20.2.ebuild b/dev-python/astng/astng-0.20.2.ebuild
deleted file mode 100644
index f98beb5dbd48..000000000000
--- a/dev-python/astng/astng-0.20.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astng/astng-0.20.2.ebuild,v 1.1 2010/09/18 23:16:53 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="Abstract Syntax Tree New Generation for logilab packages"
-HOMEPAGE="http://www.logilab.org/projects/astng/ http://pypi.python.org/pypi/logilab-astng"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz mirror://pypi/l/logilab-astng/logilab-${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.49.0"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( >=dev-python/egenix-mx-base-3.0.0 )"
-
-S="${WORKDIR}/logilab-${P}"
-
-PYTHON_MODNAME="logilab/astng"
-
-src_test() {
- testing() {
- local tpath="${T}/test-${PYTHON_ABI}"
- local spath="${tpath}$(python_get_sitedir)"
-
- mkdir -p "${spath}/logilab" || return 1
- cp -r "$(python_get_sitedir)/logilab/common" "${spath}/logilab" || return 1
-
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${tpath}" || die "Installation for tests failed with $(python_get_implementation) $(python_get_version)"
-
- # pytest uses tests placed relatively to the current directory.
- pushd "${spath}/logilab/astng" > /dev/null || return 1
- PYTHONPATH="${spath}" pytest -v || return 1
- popd > /dev/null || return 1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- deletion_of_unneeded_files() {
- # Avoid collision with dev-python/logilab-common.
- rm -f "${ED}$(python_get_sitedir)/logilab/__init__.py" || return 1
-
- # Don't install tests.
- rm -fr "${ED}$(python_get_sitedir)/logilab/astng/test" || return 1
- }
- python_execute_function -q deletion_of_unneeded_files
-}