summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 20:08:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 20:08:27 +0000
commit99bc47fa9f237e6ca5ba7381411d6fc3a1a6d1ff (patch)
treed0e32afd9f86ddab3120cc0147f9a4be2bea2d40 /dev-ruby/httpclient
parentamd64 stable, bug #316305 (diff)
downloadhistorical-99bc47fa9f237e6ca5ba7381411d6fc3a1a6d1ff.tar.gz
historical-99bc47fa9f237e6ca5ba7381411d6fc3a1a6d1ff.tar.bz2
historical-99bc47fa9f237e6ca5ba7381411d6fc3a1a6d1ff.zip
Remove old version, drop non-ruby18 support from stable candidate -r1 and add -r2 with all of them.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/ChangeLog10
-rw-r--r--dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild11
-rw-r--r--dev-ruby/httpclient/httpclient-2.1.5.2-r2.ebuild36
-rw-r--r--dev-ruby/httpclient/httpclient-2.1.5.2.ebuild33
4 files changed, 49 insertions, 41 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 900ecb6c0843..3a3b24198464 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.11 2010/05/22 15:19:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.12 2010/05/22 20:08:27 flameeyes Exp $
+
+*httpclient-2.1.5.2-r2 (22 May 2010)
+
+ 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -httpclient-2.1.5.2.ebuild, httpclient-2.1.5.2-r1.ebuild,
+ +httpclient-2.1.5.2-r2.ebuild:
+ Remove old version, drop non-ruby18 support from stable candidate -r1 and
+ add -r2 with all of them.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
httpclient-2.1.5.2-r1.ebuild:
diff --git a/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild b/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild
index 30fe5e285585..ce17ba86f38a 100644
--- a/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild
+++ b/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild,v 1.2 2010/05/22 15:19:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild,v 1.3 2010/05/22 20:08:27 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_TASK_TEST="-Ilib test"
RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
@@ -25,12 +25,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND="!dev-ruby/http-access2"
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
# tests are known to fail, but at least they fail for all
# implementations in the same way.
ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-# JRuby-specific dependency
-USE_RUBY="jruby" \
- ruby_add_rdepend ruby_targets_jruby dev-ruby/jruby-openssl
diff --git a/dev-ruby/httpclient/httpclient-2.1.5.2-r2.ebuild b/dev-ruby/httpclient/httpclient-2.1.5.2-r2.ebuild
new file mode 100644
index 000000000000..71504b118542
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.1.5.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.1.5.2-r2.ebuild,v 1.1 2010/05/22 20:08:27 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="http://dev.ctor.org/http-access2/"
+SRC_URI="http://dev.ctor.org/download/${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+# tests are known to fail, but at least they fail for all
+# implementations in the same way.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+# JRuby-specific dependency
+USE_RUBY="jruby" ruby_add_rdepend dev-ruby/jruby-openssl
diff --git a/dev-ruby/httpclient/httpclient-2.1.5.2.ebuild b/dev-ruby/httpclient/httpclient-2.1.5.2.ebuild
deleted file mode 100644
index 9f6867a82e51..000000000000
--- a/dev-ruby/httpclient/httpclient-2.1.5.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.1.5.2.ebuild,v 1.1 2009/08/23 07:47:49 graaff Exp $
-
-inherit ruby
-
-DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
-HOMEPAGE="http://dev.ctor.org/http-access2/"
-SRC_URI="http://dev.ctor.org/download/${P}.tar.gz"
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE=""
-USE_RUBY="1.8"
-
-S="${WORKDIR}/${P}"
-
-RDEPEND="!dev-ruby/http-access2"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s%^SITELIBDIR = %SITELIBDIR = \"${D}\" + %" install.rb
-}
-
-src_compile() { :; }
-
-src_install() {
- my_sitedir=$(ruby -rrbconfig -e 'print Config::CONFIG["sitedir"]')
- mkdir -p "${D}/${my_sitedir}/1.8"
- ruby install.rb
- erubydoc
-}