summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-30 18:18:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-30 18:18:16 +0000
commite4263405557b145418fedf4d66466ddb1f7b6ac0 (patch)
tree7289194f7553a8165cf3b83dbb2df5ba7f57f226 /dev-ruby/oauth2
parentFix rdoc directory. (diff)
downloadhistorical-e4263405557b145418fedf4d66466ddb1f7b6ac0.tar.gz
historical-e4263405557b145418fedf4d66466ddb1f7b6ac0.tar.bz2
historical-e4263405557b145418fedf4d66466ddb1f7b6ac0.zip
Initial impor of the OAuth2 gem, to use the new Facebook authentication APIs.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog11
-rw-r--r--dev-ruby/oauth2/Manifest14
-rw-r--r--dev-ruby/oauth2/metadata.xml5
-rw-r--r--dev-ruby/oauth2/oauth2-0.0.8.ebuild30
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
new file mode 100644
index 000000000000..e0e5a4d00ade
--- /dev/null
+++ b/dev-ruby/oauth2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ruby/oauth2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.1 2010/04/30 18:18:16 flameeyes Exp $
+
+*oauth2-0.0.8 (30 Apr 2010)
+
+ 30 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +oauth2-0.0.8.ebuild, +metadata.xml:
+ Initial impor of the OAuth2 gem, to use the new Facebook authentication
+ APIs.
+
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
new file mode 100644
index 000000000000..1de84b09397f
--- /dev/null
+++ b/dev-ruby/oauth2/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST oauth2-0.0.8.gem 10752 RMD160 343cbfb44fe8484b0941746cdfcca43eca78c2d7 SHA1 30108e2d9f47034992fc9df4ae9fb566b643a707 SHA256 d12a459e71d015707218f923c22aa654fcd2972e3f73d006a6b3710c0560cfcc
+EBUILD oauth2-0.0.8.ebuild 788 RMD160 ecfc385f26ede8334670c96e4c709928a1a51e45 SHA1 ec8f8dbc3a282596d28df5777b91c3f1944a4426 SHA256 291a2513d49a2c3077b6cb2bb42e5e3b72265abf47ac1e3dd8ea8a4d95988860
+MISC ChangeLog 413 RMD160 9412719ece9296027c049e6dc910b4419d224efd SHA1 de29f67877fd72f31cd755cf306491d61dca4f41 SHA256 e584fcb0cb1271625d5a076aa4fa00ded0fbabb1ab406ea71130268391849928
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkvbHrsACgkQAiZjviIA2XgVGACg0kISwBmompU82foLjC0azsdL
+FCoAn3b6iIoDhIYWddbJ93X/drcPPSNM
+=X07p
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/oauth2/metadata.xml b/dev-ruby/oauth2/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/oauth2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/oauth2/oauth2-0.0.8.ebuild b/dev-ruby/oauth2/oauth2-0.0.8.ebuild
new file mode 100644
index 000000000000..7ec86d54eb4b
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.0.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.0.8.ebuild,v 1.1 2010/04/30 18:18:16 flameeyes Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_TASK_DOC="rerdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/faraday"
+ruby_add_bdepend test ">=dev-ruby/rspec-1.2.9"
+
+all_ruby_prepare() {
+ sed -i -e '/check_dependencies/d' Rakefile || die
+}