summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-12 08:47:11 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-12 08:47:11 +0000
commit2d3b62525c23c8e0e873f32f85f5708c974f8b6e (patch)
treeff5783238f9c4642f7d15dcbd9daed06eb56621b /dev-ruby/rake-compiler
parentRemove old versions. (diff)
downloadhistorical-2d3b62525c23c8e0e873f32f85f5708c974f8b6e.tar.gz
historical-2d3b62525c23c8e0e873f32f85f5708c974f8b6e.tar.bz2
historical-2d3b62525c23c8e0e873f32f85f5708c974f8b6e.zip
Version bump.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/ChangeLog8
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index 1db4bd96a505..24b4ed30ad3b 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.27 2011/02/11 08:39:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.28 2011/02/12 08:43:52 graaff Exp $
+
+*rake-compiler-0.7.6 (12 Feb 2011)
+
+ 12 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +rake-compiler-0.7.6.ebuild:
+ Version bump.
11 Feb 2011; Hans de Graaff <graaff@gentoo.org>
-rake-compiler-0.7.1.ebuild:
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild
new file mode 100644
index 000000000000..33dfa1ae458d
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.7.6.ebuild,v 1.1 2011/02/12 08:43:52 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# Tests for now seem only to work when rubygems is fully installed for
+# the implementation and that for now only means Ruby 1.8
+RUBY_FAKEGEM_TASK_TEST="-f tasks/rspec.rake -f tasks/cucumber.rake spec cucumber"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="as-is" # truly
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+S="${WORKDIR}/luislavena-${PN}-*"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend "test? ( dev-ruby/rspec:0 dev-util/cucumber dev-ruby/rubygems )"
+
+ruby_add_rdepend "dev-ruby/rake"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ ewarn "Tests disabled for this implementation. Long story, check ebuild if you want."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}