summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-14 11:40:00 +0000
committerTom William Payne <twp@gentoo.org>2003-04-14 11:40:00 +0000
commit1b5afd1b4173b281d8eef5d1948990c77194f0b0 (patch)
tree6c3b1bd91cd06d8835f9ee82923648e0494b2acc /dev-ruby/ruby-ldap
parentInitial commit (diff)
downloadhistorical-1b5afd1b4173b281d8eef5d1948990c77194f0b0.tar.gz
historical-1b5afd1b4173b281d8eef5d1948990c77194f0b0.tar.bz2
historical-1b5afd1b4173b281d8eef5d1948990c77194f0b0.zip
Initial commit.
Diffstat (limited to 'dev-ruby/ruby-ldap')
-rw-r--r--dev-ruby/ruby-ldap/ChangeLog15
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.7.2.ebuild24
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.8.0.ebuild24
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/ChangeLog b/dev-ruby/ruby-ldap/ChangeLog
new file mode 100644
index 000000000000..7b2a0ffd95ed
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-ruby/ruby-ldap
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ChangeLog,v 1.1 2003/04/14 11:40:00 twp Exp $
+
+*ruby-ldap-0.8.0 (14 Apr 2003)
+
+ 14 Apr 2003; Tom Payne <twp@gentoo.org> ruby-ldap-0.8.0.ebuild :
+
+ Initial commit.
+
+*ruby-ldap-0.7.2 (14 Apr 2003)
+
+ 14 Apr 2003; Tom Payne <twp@gentoo.org> ruby-ldap-0.7.2.ebuild :
+
+ Initial commit. Ebuild submitted by Miles Egan (bug # 19170).
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.7.2.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.7.2.ebuild
new file mode 100644
index 000000000000..e37360065e81
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.7.2.ebuild,v 1.1 2003/04/14 11:40:00 twp Exp $
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="http://ruby-ldap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ruby-ldap/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=dev-lang/ruby-1.6
+ >=net-nds/openldap-2
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ ruby extconf.rb --with-openldap2
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog README* TODO
+}
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.8.0.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.8.0.ebuild
new file mode 100644
index 000000000000..23247709d143
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.8.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.8.0.ebuild,v 1.1 2003/04/14 11:40:00 twp Exp $
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="http://ruby-ldap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ruby-ldap/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=dev-lang/ruby-1.6
+ >=net-nds/openldap-2
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ ruby extconf.rb --with-openldap2
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog README* TODO
+}