summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-17 10:22:02 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-17 10:22:02 +0000
commit9f27f00e326fe9dd02d7bf853860f53e447d08ba (patch)
tree9af93f6e0d92fcbb85a83172d7963e7a81519511 /dev-ruby/selenium-webdriver
parentppc/ppc64 stable wrt #364469 (diff)
downloadhistorical-9f27f00e326fe9dd02d7bf853860f53e447d08ba.tar.gz
historical-9f27f00e326fe9dd02d7bf853860f53e447d08ba.tar.bz2
historical-9f27f00e326fe9dd02d7bf853860f53e447d08ba.zip
Initial import. Dependency of forthcoming dev-ruby/capybara. Still has a QA issue with LDFLAGS due to pre-compiled shared objects which can hopefully resolved shortly.
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/selenium-webdriver')
-rw-r--r--dev-ruby/selenium-webdriver/ChangeLog12
-rw-r--r--dev-ruby/selenium-webdriver/Manifest14
-rw-r--r--dev-ruby/selenium-webdriver/metadata.xml5
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-0.2.2.ebuild39
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/ChangeLog b/dev-ruby/selenium-webdriver/ChangeLog
new file mode 100644
index 000000000000..f319fa88af40
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-ruby/selenium-webdriver
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/ChangeLog,v 1.1 2011/07/17 10:22:02 graaff Exp $
+
+*selenium-webdriver-0.2.2 (17 Jul 2011)
+
+ 17 Jul 2011; Hans de Graaff <graaff@gentoo.org>
+ +selenium-webdriver-0.2.2.ebuild, +metadata.xml:
+ Initial import. Dependency of forthcoming dev-ruby/capybara. Still has a QA
+ issue with LDFLAGS due to pre-compiled shared objects which can hopefully
+ resolved shortly.
+
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
new file mode 100644
index 000000000000..2b40b2613b78
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST selenium-webdriver-0.2.2.gem 1579520 RMD160 a4f1a45870ce835311c8590e624e401302dfc3a7 SHA1 b3e20263744084ba63e2c75b67d46e5ae47ed7b2 SHA256 c89b4c3c075b025abd5a43a97d95f3f1948d13cd309cd7edc88478dc558f9c9b
+EBUILD selenium-webdriver-0.2.2.ebuild 1150 RMD160 d0061395b3310fa5e60b985df39cd7d888f58fd3 SHA1 f0426d4a78157c51f3a88e1f273e9c363d3b6de0 SHA256 d1b19fd036ba106ecb4b1fd3b2a9328227e06d16c6eb8d30072aea3b4ba72f16
+MISC ChangeLog 544 RMD160 07bd99416fd1a6921c62baf9e861d04b82c85fe3 SHA1 f004d1b5de70a205c131323cb0c360db9a5a376b SHA256 b0c433436a29087499302b7230efd7f86910f9c202acdc9dea9bf890fb1894fe
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk4it88ACgkQiIP6VqMIqNdEyAD9EMPthZe4yxObl0QrXpKrniWP
+dCKnpx0NGhJFXM1jKV4A/iRAY9BbacXsbZoQVS3MmA/zN3tnULQCWK86NOFJm52e
+=gUoM
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/selenium-webdriver/metadata.xml b/dev-ruby/selenium-webdriver/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-0.2.2.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-0.2.2.ebuild
new file mode 100644
index 000000000000..a9efc0e4f168
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-0.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/selenium-webdriver/selenium-webdriver-0.2.2.ebuild,v 1.1 2011/07/17 10:22:02 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at http://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver."
+HOMEPAGE="http://gemcutter.org/gems/selenium-webdriver"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.1.9
+ >=dev-ruby/ffi-1.0.7
+ dev-ruby/json
+ dev-ruby/rubyzip"
+
+all_ruby_prepare() {
+ # Match gemspec metadata up with our dependency adjustments.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}