summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2003-11-17 00:11:35 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2003-11-17 00:11:35 +0000
commit6b55171c6b1161b4a1d99d79c1f30bd189bf0fa6 (patch)
treebafe4eb8abe3ff30c907734eb0851fb6e371a304 /dev-ruby/soap4r/soap4r-1.5.1.2.ebuild
parentversion bump (diff)
downloadhistorical-6b55171c6b1161b4a1d99d79c1f30bd189bf0fa6.tar.gz
historical-6b55171c6b1161b4a1d99d79c1f30bd189bf0fa6.tar.bz2
historical-6b55171c6b1161b4a1d99d79c1f30bd189bf0fa6.zip
version bump
Diffstat (limited to 'dev-ruby/soap4r/soap4r-1.5.1.2.ebuild')
-rw-r--r--dev-ruby/soap4r/soap4r-1.5.1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/soap4r/soap4r-1.5.1.2.ebuild b/dev-ruby/soap4r/soap4r-1.5.1.2.ebuild
new file mode 100644
index 000000000000..dc4235f66a50
--- /dev/null
+++ b/dev-ruby/soap4r/soap4r-1.5.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/soap4r/soap4r-1.5.1.2.ebuild,v 1.1 2003/11/17 00:11:31 matsuu Exp $
+
+inherit ruby
+
+USE_RUBY="any"
+
+MY_P=${P//./_}
+DESCRIPTION="an implementation of SOAP 1.1"
+HOMEPAGE="http://rrr.jin.gr.jp/rwiki?cmd=view;name=soap4r"
+SRC_URI="http://rrr.jin.gr.jp/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="<dev-lang/ruby-1.8.1
+ >=dev-ruby/devel-logger-1.0.1
+ >=dev-ruby/http-access2-0j
+ >=dev-ruby/rexml-2.5.3
+ >=dev-ruby/uconv-0.4.10"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp install.rb ${T}
+ sed -e "s:^RUBYLIBDIR = :RUBYLIBDIR = \"${D}\" + :" \
+ -e "s:^SITELIBDIR = :SITELIBDIR = \"${D}\" + :" \
+ ${T}/install.rb > install.rb || die
+}