summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-02 18:07:27 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-02 18:07:27 +0000
commit5031150ef68a3bc5b75d50346eff5621043005df (patch)
tree323b43828ba5efc15317200c13adf7010d107bfc /dev-ruby
parentNew package. Delay is a sleeplike program. (diff)
downloadhistorical-5031150ef68a3bc5b75d50346eff5621043005df.tar.gz
historical-5031150ef68a3bc5b75d50346eff5621043005df.tar.bz2
historical-5031150ef68a3bc5b75d50346eff5621043005df.zip
New version. Fixes #4381. Submitted by Holden Glova
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rexml/ChangeLog10
-rw-r--r--dev-ruby/rexml/files/digest-rexml-2.3.71
-rw-r--r--dev-ruby/rexml/files/rexml-2.3.7-gentoo.diff18
-rw-r--r--dev-ruby/rexml/rexml-2.3.7.ebuild19
4 files changed, 46 insertions, 2 deletions
diff --git a/dev-ruby/rexml/ChangeLog b/dev-ruby/rexml/ChangeLog
index 3c5f8efc3787..144b077252f4 100644
--- a/dev-ruby/rexml/ChangeLog
+++ b/dev-ruby/rexml/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for dev-ruby/rexml
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rexml/ChangeLog,v 1.2 2002/06/17 08:17:41 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rexml/ChangeLog,v 1.3 2002/07/02 18:06:49 rphillips Exp $
+*rexml-2.3.7 (02 Jul 2002)
+
+ 02 Jul 2002; Ryan Phillips <rphillips@gentoo.org> rexml-2.3.7 files/digest-rexml-2.3.7 :
+
+ New Version. Fixes #4381
+
*rexml-2.3.5 (17 Jun 2002)
- 17 Jun 2002; Ryan Phillips <rphillips@gentoo.org> rexml-1.2.5 files/digest-rexml-1.2.5 :
+ 17 Jun 2002; Ryan Phillips <rphillips@gentoo.org> rexml-2.3.5 files/digest-rexml-2.3.5 :
Updated package revision. Fixes #3799
diff --git a/dev-ruby/rexml/files/digest-rexml-2.3.7 b/dev-ruby/rexml/files/digest-rexml-2.3.7
new file mode 100644
index 000000000000..03fa77d4fe97
--- /dev/null
+++ b/dev-ruby/rexml/files/digest-rexml-2.3.7
@@ -0,0 +1 @@
+MD5 116416d4ca8083de0cf16dbcf2dc3eee rexml_2.3.7.tgz 279489
diff --git a/dev-ruby/rexml/files/rexml-2.3.7-gentoo.diff b/dev-ruby/rexml/files/rexml-2.3.7-gentoo.diff
new file mode 100644
index 000000000000..eaa31d9ff51d
--- /dev/null
+++ b/dev-ruby/rexml/files/rexml-2.3.7-gentoo.diff
@@ -0,0 +1,18 @@
+--- rexml.old/bin/install.rb Mon Jul 1 21:42:34 2002
++++ rexml/bin/install.rb Mon Jul 1 21:47:23 2002
+@@ -34,9 +34,13 @@
+ [ '--help', '-h', GetoptLong::NO_ARGUMENT],
+ [ '--noop', '-n', GetoptLong::NO_ARGUMENT])
+
+-
+-destdir = File.join Config::CONFIG['sitedir'],
++if ENV["PORTAGETMP"]
++ destdir = File.join ENV["PORTAGETMP"], Config::CONFIG['sitedir'],
++ "#{Config::CONFIG['MAJOR']}.#{Config::CONFIG['MINOR']}"
++else
++ destdir = File.join Config::CONFIG['sitedir'],
+ "#{Config::CONFIG['MAJOR']}.#{Config::CONFIG['MINOR']}"
++end
+
+ uninstall = false
+ append = nil
diff --git a/dev-ruby/rexml/rexml-2.3.7.ebuild b/dev-ruby/rexml/rexml-2.3.7.ebuild
new file mode 100644
index 000000000000..025e7275cbf1
--- /dev/null
+++ b/dev-ruby/rexml/rexml-2.3.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rexml/rexml-2.3.7.ebuild,v 1.1 2002/07/02 18:06:49 rphillips Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Ruby Electric XML"
+SRC_URI="http://www.germane-software.com/archives/${PN}_${PV}.tgz"
+HOMEPAGE="http://www.germane-software.com/software/rexml/"
+DEPEND=">=dev-lang/ruby-1.6.0"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}/bin
+ patch < ${FILESDIR}/${P}-gentoo.diff || die
+}
+
+src_install () {
+ PORTAGETMP=${D} ruby bin/install.rb
+}