summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-03-27 03:54:30 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-03-27 03:54:30 +0000
commit7b0ab36264d3589749d98a8108979915b6cc6748 (patch)
tree65877971fd9dd7de51b6f98b76cc3402eb59e7ec /dev-tcltk/tcllib/tcllib-1.7.ebuild
parentStable on SPARC. (diff)
downloadhistorical-7b0ab36264d3589749d98a8108979915b6cc6748.tar.gz
historical-7b0ab36264d3589749d98a8108979915b6cc6748.tar.bz2
historical-7b0ab36264d3589749d98a8108979915b6cc6748.zip
Version bumped.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-tcltk/tcllib/tcllib-1.7.ebuild')
-rw-r--r--dev-tcltk/tcllib/tcllib-1.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-tcltk/tcllib/tcllib-1.7.ebuild b/dev-tcltk/tcllib/tcllib-1.7.ebuild
new file mode 100644
index 000000000000..77297b7a3e0c
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/tcllib-1.7.ebuild,v 1.1 2005/03/27 03:54:30 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Tcl Standard Library."
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="mirror://sourceforge/tcllib/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64 ~s390"
+
+DEPEND=">=dev-lang/tcl-8.3.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf || die
+ # emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog PACKAGES* README STATUS *.txt
+}