summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-12 17:50:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-12 17:50:37 +0000
commit2d213b5e72ce536e7aa6d6ff333e89b6108918f0 (patch)
tree63cc98707ecb43921ec62879ec67b72be4fe0c85 /dev-util/makepp
parentQuoting. Use emake. (diff)
downloadhistorical-2d213b5e72ce536e7aa6d6ff333e89b6108918f0.tar.gz
historical-2d213b5e72ce536e7aa6d6ff333e89b6108918f0.tar.bz2
historical-2d213b5e72ce536e7aa6d6ff333e89b6108918f0.zip
Fix quoting
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'dev-util/makepp')
-rw-r--r--dev-util/makepp/makepp-1.18.ebuild11
-rw-r--r--dev-util/makepp/makepp-1.40.1a.ebuild6
2 files changed, 9 insertions, 8 deletions
diff --git a/dev-util/makepp/makepp-1.18.ebuild b/dev-util/makepp/makepp-1.18.ebuild
index a06991fb6714..d3e0ca0425fc 100644
--- a/dev-util/makepp/makepp-1.18.ebuild
+++ b/dev-util/makepp/makepp-1.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/makepp/makepp-1.18.ebuild,v 1.1 2005/09/22 06:27:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/makepp/makepp-1.18.ebuild,v 1.2 2009/10/12 17:50:37 ssuominen Exp $
inherit eutils
@@ -16,14 +16,15 @@ DEPEND=">=dev-lang/perl-5.6.0"
src_unpack() {
unpack ${A}
- cd ${S}; epatch ${FILESDIR}/${P}-install.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-install.patch
# There is a sandbox violation in this test.
# In future versions, this ebuild should try to find
# a better way of avoiding this, but the current version
# appears to have garbage NUL characters all over the test files,
# making them complicated to edit.
# Robert Coie <rac@gentoo.org> 2002.02.18
- rm ${S}/makepp_tests/include.test
+ rm "${S}"/makepp_tests/include.test
}
src_compile() {
@@ -31,5 +32,5 @@ src_compile() {
}
src_install() {
- perl install.pl /usr ${D} /usr/bin /usr/share/makepp /usr/share/doc/makepp
+ perl install.pl /usr "${D}" /usr/bin /usr/share/makepp /usr/share/doc/makepp
}
diff --git a/dev-util/makepp/makepp-1.40.1a.ebuild b/dev-util/makepp/makepp-1.40.1a.ebuild
index e687c6a72de8..329672f7f187 100644
--- a/dev-util/makepp/makepp-1.40.1a.ebuild
+++ b/dev-util/makepp/makepp-1.40.1a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/makepp/makepp-1.40.1a.ebuild,v 1.1 2005/09/22 06:27:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/makepp/makepp-1.40.1a.ebuild,v 1.2 2009/10/12 17:50:37 ssuominen Exp $
inherit eutils
@@ -37,6 +37,6 @@ src_compile() {
}
src_install() {
- make install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}" || die
dodoc ChangeLog README
}