summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2004-06-01 21:36:45 +0000
committerWolfram Schlich <wschlich@gentoo.org>2004-06-01 21:36:45 +0000
commit1b9d8aa296cabd207d1d32a75bc1103f0e7265ec (patch)
tree358fdbc620e70d3b06cf7f85963c6aa9da0994ae /dev-util/sel/sel-0.08.4.ebuild
parentstable on amd64 (diff)
downloadhistorical-1b9d8aa296cabd207d1d32a75bc1103f0e7265ec.tar.gz
historical-1b9d8aa296cabd207d1d32a75bc1103f0e7265ec.tar.bz2
historical-1b9d8aa296cabd207d1d32a75bc1103f0e7265ec.zip
version bump
Diffstat (limited to 'dev-util/sel/sel-0.08.4.ebuild')
-rw-r--r--dev-util/sel/sel-0.08.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/sel/sel-0.08.4.ebuild b/dev-util/sel/sel-0.08.4.ebuild
new file mode 100644
index 000000000000..a8e70ef74c72
--- /dev/null
+++ b/dev-util/sel/sel-0.08.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sel/sel-0.08.4.ebuild,v 1.1 2004/06/01 21:36:45 wschlich Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A filemanager for shell scripts"
+SRC_URI="http://www.rninet.de/darkstar/files/${P}.tar.gz"
+HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~s390"
+
+DEPEND=">=sys-libs/ncurses-5.1"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+
+ cp Makefile Makefile.orig
+ sed -e "s:-m486:${CFLAGS}:" -e "s:-O3::" Makefile.orig > Makefile
+
+ cp sel.c sel.c.orig
+ sed -e "s:/usr/local/share/sel/help\.txt:/usr/share/sel/help\.txt:" \
+ sel.c.orig > sel.c
+}
+
+src_compile() {
+ make || die
+}
+
+src_install () {
+ dobin sel
+ doman sel.1
+ insinto /usr/share/sel
+ doins help.txt
+ dodoc Changelog LICENSE
+}