summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-09-15 23:01:28 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-09-15 23:01:28 +0000
commit940bf5913d6be4765f2fd1733a37d64148c43a36 (patch)
tree691e310ba17d5aed97c9c295f6bcc50e03f765f6 /dev-util/shunit2/shunit2-2.1.4.ebuild
parent0.12 release, removed -gtk option (diff)
downloadhistorical-940bf5913d6be4765f2fd1733a37d64148c43a36.tar.gz
historical-940bf5913d6be4765f2fd1733a37d64148c43a36.tar.bz2
historical-940bf5913d6be4765f2fd1733a37d64148c43a36.zip
New package: shUnit2 is a unit-test framework for Bourne-based shell scripts (Toffanin Mauro, GeCHI overlay).
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.27-rc6 x86_64
Diffstat (limited to 'dev-util/shunit2/shunit2-2.1.4.ebuild')
-rw-r--r--dev-util/shunit2/shunit2-2.1.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/shunit2/shunit2-2.1.4.ebuild b/dev-util/shunit2/shunit2-2.1.4.ebuild
new file mode 100644
index 000000000000..b9ed9430a63c
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.4.ebuild,v 1.1 2008/09/15 23:01:28 dberkholz Exp $
+
+DESCRIPTION="shUnit2 is a unit-test framework for Bourne-based shell scripts."
+HOMEPAGE="http://code.google.com/p/shunit2/wiki/ProjectInfo"
+SRC_URI="http://shunit2.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ net-misc/curl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^__SHUNIT_SHELL_FLAGS/s:u::' src/shell/shunit2
+}
+
+src_compile() {
+ local myconf="build"
+ use doc && myconf="${myconf} docs"
+ use test && myconf="${myconf} test"
+
+ emake ${myconf} || die
+}
+
+src_install() {
+ if use doc; then
+ for DOC in build/{docbook/*,shunit2.html,shunit2_shelldoc.xml}; do
+ dodoc ${DOC} || die
+ rm ${DOC}
+ done
+ fi
+
+ dodoc doc/*.txt || die
+
+ insinto /usr/share/${PN}
+ doins build/* || die
+}