summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-10-17 14:22:39 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-10-17 14:22:39 +0000
commit952257811550f1751f1414e93c7566c92a3ce7dc (patch)
tree70d7729652fd917f9d19237f63b1a53b0e4b4527 /dev-util/source-highlight/source-highlight-2.2.ebuild
parentfrancesco 4 gentoo (diff)
downloadhistorical-952257811550f1751f1414e93c7566c92a3ce7dc.tar.gz
historical-952257811550f1751f1414e93c7566c92a3ce7dc.tar.bz2
historical-952257811550f1751f1414e93c7566c92a3ce7dc.zip
Version bump.
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'dev-util/source-highlight/source-highlight-2.2.ebuild')
-rw-r--r--dev-util/source-highlight/source-highlight-2.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/source-highlight/source-highlight-2.2.ebuild b/dev-util/source-highlight/source-highlight-2.2.ebuild
new file mode 100644
index 000000000000..900c851bdc1c
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-2.2.ebuild,v 1.1 2005/10/17 14:22:39 ka0ttic Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="ftp://ftp.gnu.org/gnu/src-highlite/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="dev-libs/boost
+ dev-util/ctags"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-exuberant-ctags.diff
+}
+
+src_compile() {
+ local myconf
+
+ einfo "Regenerating autoconf/automake files"
+ libtoolize --copy --force || die "libtoolize failed"
+ aclocal || die "aclocal failed"
+ autoheader || die "autoheader failed"
+ automake --add-missing --copy || die "automake failed"
+ autoconf || die "autoconf failed"
+
+ built_with_use dev-libs/boost threadsonly && \
+ myconf="--with-boost-regex=boost_regex-gcc-mt"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ rm -fr ${D}/usr/share/doc
+
+ dodoc AUTHORS ChangeLog COPYING CREDITS INSTALL \
+ NEWS README THANKS TODO.txt || die
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion ${PN}
+
+ if use doc ; then
+ cd ${S}/doc
+ dohtml *.html *.css *.java
+ fi
+}