summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-06-30 19:37:07 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-06-30 19:37:07 +0000
commit3cbac06c1448d8fa26b4cd4fa1796c093ae4c054 (patch)
tree105d5935c9d2984836be989dee91675d6ee6da8d /dev-util
parentRenaming binary ebuil of eclipse, previously called eclipse-SDK, to eclipse-s... (diff)
downloadhistorical-3cbac06c1448d8fa26b4cd4fa1796c093ae4c054.tar.gz
historical-3cbac06c1448d8fa26b4cd4fa1796c093ae4c054.tar.bz2
historical-3cbac06c1448d8fa26b4cd4fa1796c093ae4c054.zip
Renaming binary ebuil of eclipse, previously called eclipse-SDK, to eclipse-sdk-bin.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-sdk-bin/Manifest4
-rw-r--r--dev-util/eclipse-sdk-bin/eclipse-sdk-bin-2.1.ebuild79
-rw-r--r--dev-util/eclipse-sdk-bin/files/digest-eclipse-sdk-bin-2.11
-rw-r--r--dev-util/eclipse-sdk-bin/files/eclipse.desktop8
4 files changed, 90 insertions, 2 deletions
diff --git a/dev-util/eclipse-sdk-bin/Manifest b/dev-util/eclipse-sdk-bin/Manifest
index 6dbe6f12b3ba..900e8b1d7aa4 100644
--- a/dev-util/eclipse-sdk-bin/Manifest
+++ b/dev-util/eclipse-sdk-bin/Manifest
@@ -1,4 +1,4 @@
-MD5 ba06d3c1952a03671dffe01ee5632484 ChangeLog 1999
-MD5 b699b40fed9981f7b6579ff72660aef6 eclipse-sdk-bin-2.1.ebuild 2438
+MD5 76baf4a96f2131f4e4d3e29c60b81456 ChangeLog 2000
+MD5 9da0ad9596c56779e6a4af7f5cad1015 eclipse-sdk-bin-2.1.ebuild 2444
MD5 30eaad948ddfef2843cd28c52bd5b362 files/digest-eclipse-sdk-bin-2.1 76
MD5 b7d91171809903d55e187961bb62f731 files/eclipse.desktop 173
diff --git a/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-2.1.ebuild b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-2.1.ebuild
new file mode 100644
index 000000000000..35ca45e372a9
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-2.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-2.1.ebuild,v 1.1 2003/06/30 19:36:55 karltk Exp $
+
+DESCRIPTION="Eclipse Tools Platform"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download2.eclipse.org/downloads/drops/R-2.1-200303272130/eclipse-SDK-2.1-linux-gtk.zip"
+IUSE=""
+
+SLOT="0"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.3
+ ppc? ( app-shells/tcsh )"
+
+RDEPEND=">=virtual/jdk-1.3
+ >=x11-libs/gtk+-2.2.1-r1
+ =gnome-base/gnome-vfs-2*"
+
+S=${WORKDIR}/eclipse
+
+src_compile() {
+
+ if [ "`use ppc`" ]
+ then
+ # build the SWT library
+ library_dir=${S}/plugins/org.eclipse.platform.linux.gtk.source_2.1.0/src/org.eclipse.swt.gtk_2.1.0/ws/gtk/library
+ mkdir ${library_dir}
+ cd ${library_dir}
+ unzip -q ../swtsrc.zip
+ unzip -q ../swt-pisrc.zip
+ sed -e "s:/bluebird/teamswt/swt-builddir/ive:\$(JAVA_HOME):" \
+ -e "s:JAVA_JNI=\$(IVE_HOME)/bin/include:JAVA_JNI=\$(IVE_HOME)/include:" \
+ -e "s:\`pkg-config --libs gthread-2.0\`:-lpthread -lgthread-2.0 -lglib-2.0:" \
+ -e "s:\`pkg-config --libs gnome-vfs-2.0\`:-lpthread -lgnomevfs-2 -lbonobo-activation -lORBit-2 -lm -llinc -lgmodule-2.0 -ldl -lgobject-2.0 -lgthread-2.0 -lglib-2.0:" \
+ make_gtk.mak > make_gtk.mak_new
+ cp make_gtk.mak_new make_gtk.mak
+
+ sh build.sh || die
+
+ # move the SWT library to the correct location and clean up
+ mkdir ${S}/plugins/org.eclipse.swt.gtk_2.1.0/os/linux/ppc
+ mv *.so ${S}/plugins/org.eclipse.swt.gtk_2.1.0/os/linux/ppc
+ rm -rf ${S}/plugins/org.eclipse.swt.gtk_2.1.0/os/linux/x86
+ cd ${S}
+ rm -rf ${library_dir}
+
+ # build the executable
+ bin_dir=${S}/plugins/org.eclipse.platform.source_2.1.0/src/org.eclipse.platform_2.1.0/bin
+ mkdir ${bin_dir}
+ cd ${bin_dir}
+ unzip -q ../launchersrc.zip
+ cd library/gtk
+ tcsh build.csh -arch ppc || die
+
+ # move the executable to the correct location and clean up
+ cp eclipse ${S}
+ cd ${S}
+ rm -rf ${bin_dir}
+ fi
+}
+
+src_install() {
+ dodir /opt/eclipse
+
+ cp -dpR features install.ini eclipse \
+ icon.xpm plugins startup.jar \
+ ${D}/opt/eclipse/
+
+ dohtml cpl-v10.html notice.html readme/*
+
+ insinto /usr/share/gnome/apps/Development
+ doins ${FILESDIR}/eclipse.desktop
+
+ dodir /etc/env.d
+ echo -e "LDPATH=/opt/eclipse\nPATH=/opt/eclipse\nROOTPATH=/opt/eclipse" > ${D}/etc/env.d/20eclipse
+}
diff --git a/dev-util/eclipse-sdk-bin/files/digest-eclipse-sdk-bin-2.1 b/dev-util/eclipse-sdk-bin/files/digest-eclipse-sdk-bin-2.1
new file mode 100644
index 000000000000..2720d5d16fb0
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/files/digest-eclipse-sdk-bin-2.1
@@ -0,0 +1 @@
+MD5 0960d97a29cfa88b5d407e73053c77c4 eclipse-SDK-2.1-linux-gtk.zip 64248568
diff --git a/dev-util/eclipse-sdk-bin/files/eclipse.desktop b/dev-util/eclipse-sdk-bin/files/eclipse.desktop
new file mode 100644
index 000000000000..dfb887fbe720
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/files/eclipse.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Eclipse
+Comment=A Java Development Environment
+Icon=/opt/eclipse/icon.xpm
+Exec=/opt/eclipse/eclipse
+Terminal=false
+Type=Application
+StartupNotify=false