summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-03-07 12:38:50 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-03-07 12:38:50 +0000
commitc9538439a75816343a70e77246652067d2624bbc (patch)
tree0fa0740046ef33c49616cbed42e4553f3c359952 /dev-vcs/git-sh
parentPrefix cleaning, keyworded for *-linux, tested by me (diff)
downloadhistorical-c9538439a75816343a70e77246652067d2624bbc.tar.gz
historical-c9538439a75816343a70e77246652067d2624bbc.tar.bz2
historical-c9538439a75816343a70e77246652067d2624bbc.zip
Moving from dev-util to dev-vcs
Diffstat (limited to 'dev-vcs/git-sh')
-rw-r--r--dev-vcs/git-sh/ChangeLog21
-rw-r--r--dev-vcs/git-sh/Manifest14
-rw-r--r--dev-vcs/git-sh/git-sh-1.0-r1.ebuild37
-rw-r--r--dev-vcs/git-sh/metadata.xml12
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-vcs/git-sh/ChangeLog b/dev-vcs/git-sh/ChangeLog
new file mode 100644
index 000000000000..d031fca6e879
--- /dev/null
+++ b/dev-vcs/git-sh/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for dev-vcs/git-sh
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/ChangeLog,v 1.1 2010/03/07 12:38:50 ayoy Exp $
+
+ 07 Mar 2010; Dominik Kapusta <ayoy@gentoo.org> +git-sh-1.0-r1.ebuild,
+ +metadata.xml:
+ Moving from dev-util to dev-vcs
+
+*git-sh-1.0-r1 (29 Nov 2009)
+
+ 29 Nov 2009; Dominik Kapusta <ayoy@gentoo.org> -git-sh-1.0.ebuild,
+ +git-sh-1.0-r1.ebuild:
+ Remove git bash completion script, as it's delivered with git itself
+
+*git-sh-1.0 (28 Nov 2009)
+
+ 28 Nov 2009; Dominik Kapusta <ayoy@gentoo.org> +git-sh-1.0.ebuild,
+ +metadata.xml:
+ Initial commit for git-sh (bug #294667). Thanks to Gaston Jorguera
+ (gjorguera@gmail.com) for the initial ebuild.
+
diff --git a/dev-vcs/git-sh/Manifest b/dev-vcs/git-sh/Manifest
new file mode 100644
index 000000000000..a97c8bb685e8
--- /dev/null
+++ b/dev-vcs/git-sh/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST git-sh-1.0.tar.gz 22466 RMD160 b4c8de201c1b992f6cc20eadb631e6f2d11eaece SHA1 4021fb883bd76bfa2e759a8ed2a9e9e960b06519 SHA256 6f9dc94a24351a2511ebb8f4335ee6742e950128b762453fc5677add3ba164c4
+EBUILD git-sh-1.0-r1.ebuild 941 RMD160 5344a591f620be0e2df7b2c9ab9066c36aaae9ff SHA1 f8680318a64657b3cfc4350c26bb984b34f384bf SHA256 62f8071ac285cf463f68744d67735e2af2973109def183fe9e3194447a2b0119
+MISC ChangeLog 750 RMD160 42a74cb08fc97691a7ce5d74daab62c7a1cb57a6 SHA1 346268dcbe0c8d4b6ea9358f3d8b9d9410183f66 SHA256 78eeb49f82ef0d5881c55bd045bebaa89478426914ea7a3d357e19787284075f
+MISC metadata.xml 304 RMD160 b37daf8603f6bfa52a05c42ea07cd4edab59c533 SHA1 db5bc2c765a8630f493869179887c18f11b0c189 SHA256 37fa698a1cdfa82f483a52ea06da86b4ae4fe91f6fbf55b44808be8da50b2241
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkuTnm8ACgkQ+CZEqwt+F6YwmACggENJdE8BQxs+SAF4erbL2BPw
+x38An0d7FxyqVqEKvCg76PsCc1KKVq7l
+=jXAF
+-----END PGP SIGNATURE-----
diff --git a/dev-vcs/git-sh/git-sh-1.0-r1.ebuild b/dev-vcs/git-sh/git-sh-1.0-r1.ebuild
new file mode 100644
index 000000000000..4c0812f21aa7
--- /dev/null
+++ b/dev-vcs/git-sh/git-sh-1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/git-sh-1.0-r1.ebuild,v 1.1 2010/03/07 12:38:50 ayoy Exp $
+
+EAPI="2"
+
+DESCRIPTION="A customized bash environment suitable for git work."
+HOMEPAGE="http://github.com/rtomayko/git-sh"
+SRC_URI="http://github.com/rtomayko/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-util/git"
+
+S="${WORKDIR}/rtomayko-${PN}-bedba53"
+
+src_prepare() {
+ sed -e 's/git-completion\.bash //' -i Makefile || die "sed failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ insinto /usr/share/${PN}
+ doins gitshrc-example.bash || die "doins failed"
+ dodoc README.markdown || die "dodoc failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "For bash completion in git commands emerge dev-util/git"
+ einfo "with bash-completion USE flag."
+ einfo
+}
diff --git a/dev-vcs/git-sh/metadata.xml b/dev-vcs/git-sh/metadata.xml
new file mode 100644
index 000000000000..a08205a8ebe9
--- /dev/null
+++ b/dev-vcs/git-sh/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ayoy@gentoo.org</email>
+ <name>Dominik Kapusta</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
+