summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-22 22:38:22 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-22 22:38:22 +0000
commitec3cf5faadb316cc58bf77c63cc60427e2876c8e (patch)
tree03cd6aa7d2756a157fee2be8649f66b4a883c307 /eclass/autotools.eclass
parentVersion bump. Cleaning. Add UNIVERSAL-require to RDEPEND (#210120) (diff)
downloadhistorical-ec3cf5faadb316cc58bf77c63cc60427e2876c8e.tar.gz
historical-ec3cf5faadb316cc58bf77c63cc60427e2876c8e.tar.bz2
historical-ec3cf5faadb316cc58bf77c63cc60427e2876c8e.zip
rip out ACLOCAL_AMFLAGS from Makefiles #142787
Diffstat (limited to 'eclass/autotools.eclass')
-rw-r--r--eclass/autotools.eclass9
1 files changed, 8 insertions, 1 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index f97d56970791..7d94588978cd 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.73 2008/03/31 14:19:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.74 2008/04/22 22:38:22 vapier Exp $
#
# Maintainer: base-system@gentoo.org
#
@@ -117,6 +117,13 @@ eautoreconf() {
eaclocal() {
local aclocal_opts
+ local amflags_file
+ for amflags_file in GNUmakefile.am Makefile.am GNUmakefile.in Makefile.in ; do
+ [[ -e ${amflags_file} ]] || continue
+ aclocal_opts=$(sed -n '/^ACLOCAL_AMFLAGS[[:space:]]*=/s:[^=]*=::p' ${amflags_file})
+ break
+ done
+
if [[ -n ${AT_M4DIR} ]] ; then
for x in ${AT_M4DIR} ; do
case "${x}" in