summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-09 10:21:49 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-09 10:21:49 +0000
commit1867b2e3788972448bc1d8a835951e36f436c6da (patch)
tree2838d5928633f7ac3b29a91f2a668a96e274e05d /eclass/x-modular.eclass
parentDetect variables given default values via :${var:=val}. (diff)
downloadhistorical-1867b2e3788972448bc1d8a835951e36f436c6da.tar.gz
historical-1867b2e3788972448bc1d8a835951e36f436c6da.tar.bz2
historical-1867b2e3788972448bc1d8a835951e36f436c6da.zip
tweak handling of default vars so that eclass-manpages can better pick things out
Diffstat (limited to 'eclass/x-modular.eclass')
-rw-r--r--eclass/x-modular.eclass18
1 files changed, 5 insertions, 13 deletions
diff --git a/eclass/x-modular.eclass b/eclass/x-modular.eclass
index b905837e51d9..b7ba3f0c49f9 100644
--- a/eclass/x-modular.eclass
+++ b/eclass/x-modular.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.117 2009/11/28 10:25:37 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/x-modular.eclass,v 1.118 2009/12/09 10:21:49 vapier Exp $
#
# @ECLASS: x-modular.eclass
# @MAINTAINER:
@@ -67,13 +67,11 @@ XDIR="/usr"
IUSE=""
HOMEPAGE="http://xorg.freedesktop.org/"
-if [[ -z ${SNAPSHOT} ]]; then
# @ECLASS-VARIABLE: SNAPSHOT
# @DESCRIPTION:
# If set to 'yes' and configure.ac exists, eautoreconf will run. Set
# before inheriting this eclass.
- SNAPSHOT="no"
-fi
+: ${SNAPSHOT:=no}
# Set up SRC_URI for individual modular releases
BASE_INDIVIDUAL_URI="http://xorg.freedesktop.org/releases/individual"
@@ -83,7 +81,6 @@ BASE_INDIVIDUAL_URI="http://xorg.freedesktop.org/releases/individual"
# doc, data, util, driver, font, lib, proto, xserver. Set above the
# inherit to override the default autoconfigured module.
if [[ -z ${MODULE} ]]; then
- MODULE=""
case ${CATEGORY} in
app-doc) MODULE="doc" ;;
media-fonts) MODULE="font" ;;
@@ -130,17 +127,13 @@ if [[ -n "${FONT}" ]]; then
# Starting with 7.0RC3, we can specify the font directory
# But oddly, we can't do the same for encodings or font-alias
- # Wrap in `if` so ebuilds can set it too
- if [[ -z ${FONT_DIR} ]]; then
# @ECLASS-VARIABLE: FONT_DIR
# @DESCRIPTION:
# If you're creating a font package and the suffix of PN is not equal to
# the subdirectory of /usr/share/fonts/ it should install into, set
# FONT_DIR to that directory or directories. Set before inheriting this
# eclass.
- FONT_DIR=${PN##*-}
-
- fi
+ : ${FONT_DIR:=${PN##*-}}
# Fix case of font directories
FONT_DIR=${FONT_DIR/ttf/TTF}
@@ -395,8 +388,7 @@ x-modular_src_configure() {
# @VARIABLE: CONFIGURE_OPTIONS
# @DESCRIPTION:
-# Any options to pass to configure
-[[ -n ${CONFIGURE_OPTIONS} ]]
+# Any extra options to pass to configure
# If prefix isn't set here, .pc files cause problems
if [[ -x ${ECONF_SOURCE:-.}/configure ]]; then
@@ -461,7 +453,7 @@ x-modular_src_install() {
fi
# @VARIABLE: DOCS
# @DESCRIPTION:
-# Any documentation to install
+# Any documentation to install via dodoc
[[ -n ${DOCS} ]] && dodoc ${DOCS}
# Don't install libtool archives for server modules