summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-12-07 18:08:41 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-12-07 18:08:41 +0000
commit6212934bac2180c2a7eda183bbea38e34ac7dc48 (patch)
treeb910a2c047e3ff8a299a8619d934b5572812d71b /eclass
parent(#114750) Somehow forgot to remove old font functionality, thus breaking FONT... (diff)
downloadhistorical-6212934bac2180c2a7eda183bbea38e34ac7dc48.tar.gz
historical-6212934bac2180c2a7eda183bbea38e34ac7dc48.tar.bz2
historical-6212934bac2180c2a7eda183bbea38e34ac7dc48.zip
Try to avoid sandbox violations thanks to silly glib misfeature. Bug #114475
Diffstat (limited to 'eclass')
-rw-r--r--eclass/vim.eclass7
1 files changed, 6 insertions, 1 deletions
diff --git a/eclass/vim.eclass b/eclass/vim.eclass
index dd57d58a3599..f1a6365dab77 100644
--- a/eclass/vim.eclass
+++ b/eclass/vim.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.130 2005/12/07 17:56:12 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.131 2005/12/07 18:08:41 ciaranm Exp $
# Authors:
# Ryan Phillips <rphillips@gentoo.org>
@@ -322,6 +322,11 @@ tr '\\267' '.' | col -b | \\
END
fi
+ # Try to avoid sandbox problems. Bug #114475.
+ if [[ $(get_major_version ) -ge 7 ]] ; then
+ sed -i -e '/-S check.vim/s, -u, -X&,' "${S}/src/po/Makefile"
+ fi
+
}
vim_src_compile() {