summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-09 12:00:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-09 12:00:34 +0000
commitbe18d441557b3908efc5cb4c55f3a8fb30f4cae5 (patch)
tree2ddcb645a97ae8ad24722857b22b2f5059fe2bdc /eclass
parentRemoving conditional patching + fixes for ppc-macos (diff)
downloadhistorical-be18d441557b3908efc5cb4c55f3a8fb30f4cae5.tar.gz
historical-be18d441557b3908efc5cb4c55f3a8fb30f4cae5.tar.bz2
historical-be18d441557b3908efc5cb4c55f3a8fb30f4cae5.zip
Pass --foreign to automake when required files (for default GNU behavior) are not found.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/autotools.eclass10
1 files changed, 8 insertions, 2 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 4c0a314fd07a..49bf89a80aa9 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.23 2005/10/08 16:02:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.24 2005/10/09 12:00:34 flameeyes Exp $
#
# Author: Diego Pettenò <flameeyes@gentoo.org>
# Enhancements: Martin Schlemmer <azarah@gentoo.org>
@@ -140,9 +140,15 @@ eautoconf() {
}
eautomake() {
+ local extra_opts
+
[[ -f Makefile.am ]] || return 0
+
+ [[ -f INSTALL && -f AUTHORS && -f ChangeLog ]] \
+ || extra_opts="${extra_opts} --foreign"
+
# --force-missing seems not to be recognized by some flavours of automake
- autotools_run_tool automake --add-missing --copy "$@"
+ autotools_run_tool automake --add-missing --copy ${extra_opts} "$@"
}