summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-08-15 15:29:58 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-08-15 15:29:58 +0000
commitc9123d3218ef9ef973ff274ff24e30bfdfbd484c (patch)
tree9aae0495fb0a9112f439490faef109559fef9f15 /eclass
parentRevision bump. Slotted bcprov dependency. Dropped old / broken revision. (diff)
downloadhistorical-c9123d3218ef9ef973ff274ff24e30bfdfbd484c.tar.gz
historical-c9123d3218ef9ef973ff274ff24e30bfdfbd484c.tar.bz2
historical-c9123d3218ef9ef973ff274ff24e30bfdfbd484c.zip
Remove dependencies and actions that are now handled in individual ebuilds.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/kde4-base.eclass24
-rw-r--r--eclass/kde4-meta.eclass34
3 files changed, 8 insertions, 56 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index da9bb76dd857..d5e7bf4183d0 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.928 2013/08/15 15:10:05 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.929 2013/08/15 15:29:58 kensington Exp $
+
+ 15 Aug 2013; Michael Palimaka <kensington@gentoo.org> kde4-base.eclass,
+ kde4-meta.eclass:
+ Remove dependencies and actions that are now handled in individual ebuilds.
15 Aug 2013; Michael Palimaka <kensington@gentoo.org> kde4-base.eclass,
kde4-functions.eclass, kde4-meta.eclass:
diff --git a/eclass/kde4-base.eclass b/eclass/kde4-base.eclass
index fe4c81c88819..57e8ccc48c94 100644
--- a/eclass/kde4-base.eclass
+++ b/eclass/kde4-base.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.129 2013/08/15 15:10:05 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.130 2013/08/15 15:29:58 kensington Exp $
# @ECLASS: kde4-base.eclass
# @MAINTAINER:
@@ -378,28 +378,6 @@ case ${KDE_SELINUX_MODULE} in
;;
esac
-# These dependencies are added as they are unconditionally required by kde-workspace.
-# They are not necessarily required by individual applications but are pulled in to prevent
-# bugs like bug #444438. This list is subject to change in the future so do not rely on it
-# in ebuilds - always set correct dependencies.
-case ${KMNAME} in
- kde-workspace)
- kdedepend+="
- x11-libs/xcb-util
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libxkbfile
- x11-libs/libXrandr
- x11-libs/libXrender
- "
- ;;
- *)
- ;;
-esac
-
# We always need the aqua useflag because otherwise we cannot = refer to it inside
# add_kdebase_dep. This was always kind of a bug, but came to light with EAPI=5
# (where referring to a use flag not in IUSE masks the ebuild).
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index 6ab62dcea74c..a4bc0a18f87b 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.71 2013/08/15 15:10:05 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.72 2013/08/15 15:29:58 kensington Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -24,9 +24,6 @@ EXPORT_FUNCTIONS ${KDEMETA_EXPF}
# Add dependencies that all packages in a certain module share.
case ${KMNAME} in
- kdebase|kdebase-apps|kde-baseapps|kdebase-workspace|kde-workspace|kdebase-runtime|kde-runtime|kdegraphics)
- COMMONDEPEND+=" >=media-libs/qimageblitz-0.0.4"
- ;;
kdepim|kdepim-runtime)
case ${PN} in
akregator|kaddressbook|kjots|kmail|knode|knotes|korganizer|ktimetracker)
@@ -511,7 +508,7 @@ kde4-meta_change_cmakelists() {
"${S}"/CMakeLists.txt || die "${LINENO}: sed died removing kde-workspace opengl dependency"
fi
;;
- kdebase-runtime | kde-runtime)
+ kde-runtime)
# COLLISION PROTECT section
# Only install the kde4 script as part of kde-base/kdebase-data
if [[ ${PN} != kdebase-data && -f CMakeLists.txt ]]; then
@@ -551,14 +548,6 @@ kde4-meta_change_cmakelists() {
;;
esac
;;
- kdewebdev)
- # Disable hardcoded checks
- sed -e 's/find_package(KdepimLibs REQUIRED)/macro_optional_find_package(KdepimLibs)/' \
- -e 's/find_package(LibXml2 REQUIRED)/macro_optional_find_package(LibXml2)/' \
- -e 's/find_package(LibXslt REQUIRED)/macro_optional_find_package(LibXslt)/' \
- -e 's/find_package(Boost REQUIRED)/macro_optional_find_package(Boost)/' \
- -i CMakeLists.txt || die "failed to disable hardcoded checks"
- ;;
esac
popd > /dev/null
@@ -571,25 +560,6 @@ kde4-meta_change_cmakelists() {
kde4-meta_src_configure() {
debug-print-function ${FUNCNAME} "$@"
- # backwards-compatibility: make mycmakeargs an array, if it isn't already
- if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
- mycmakeargs=(${mycmakeargs})
- fi
-
- # Set some cmake default values here (usually workarounds for automagic deps)
- case ${KMNAME} in
- kdewebdev)
- mycmakeargs=(
- -DWITH_KdepimLibs=OFF
- -DWITH_LibXml2=OFF
- -DWITH_LibXslt=OFF
- -DWITH_Boost=OFF
- -DWITH_LibTidy=OFF
- "${mycmakeargs[@]}"
- )
- ;;
- esac
-
kde4-base_src_configure
}